Bug 518589 - /usr/lib64/xorg/modules/input/vmmouse_drv.so: undefined symbol: xf86LoaderReqSymLists
Summary: /usr/lib64/xorg/modules/input/vmmouse_drv.so: undefined symbol: xf86LoaderReq...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vmmouse
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-21 07:39 UTC by Tomasz Torcz
Modified: 2009-08-27 18:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-27 18:28:18 UTC


Attachments (Terms of Use)

Description Tomasz Torcz 2009-08-21 07:39:55 UTC
Description of problem:
Can't start Xorg in VMware machine because of this error:

(II) config/hal: Adding input device ImPS/2 Generic Wheel Mouse
(II) Loading /usr/lib64/xorg/modules/input/vmmouse_drv.so
(II) Module vmmouse: vendor="X.Org Foundation"
	compiled for 1.6.99.1, module version = 12.6.5
/usr/bin/Xorg: symbol lookup error: /usr/lib64/xorg/modules/input/vmmouse_drv.so: undefined symbol: xf86LoaderReqSymLists




Version-Release number of selected component (if applicable):
xorg-x11-drv-vmmouse-12.6.5-1.fc12.x86_64

(today's rawhide)

Comment 1 Charlie Moschel 2009-08-22 01:53:57 UTC
I can confirm this on i686 too, but in my case the undefined symbol error never made it to the log file: I was left with a black unresponsive screen, no X running, and a log file that ends abruptly:

(II) LoadModule: "vmmouse"
(II) Loading /usr/lib/xorg/modules/input/vmmouse_drv.so
(II) Module vmmouse: vendor="X.Org Foundation"
        compiled for 1.6.99.1, module version = 12.6.5
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 7.0

Ssh'ing in and starting X from a terminal does show the undefined symbol error message as above.

I haven't been able to start X for a few weeks now, probably since updating xorg-x11-drv-vmmouse-12.6.5-1.fc12.i686 on 6-Aug, but it wasn't until today I thought to try to start X from a terminal.

Reverting to xorg-x11-drv-vmmouse-12.6.4-2.fc12.i586.rpm solves the problem for now.

Comment 2 Adam Jackson 2009-08-27 18:28:18 UTC
Fixed in 12.6.5-2.fc12


Note You need to log in before you can comment on or make changes to this bug.