Bug 518593 - evolution-exchange fails to start when evolution starts
Summary: evolution-exchange fails to start when evolution starts
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-exchange
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2009-08-21 08:03 UTC by Paul F. Johnson
Modified: 2009-08-24 12:09 UTC (History)
2 users (show)

Fixed In Version: evolution-exchange-2.27.91-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2009-08-24 12:09:53 UTC
Type: ---

Attachments (Terms of Use)

Description Paul F. Johnson 2009-08-21 08:03:54 UTC
Description of problem:
When I fire up evolution, evolution-exchange fails to start. The only server my system connects to (and is configured for) is an exchange server.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. start evolution
2. open a terminal, ps aux | grep "exchange"
Actual results:
exchange has not started

Expected results:
exchange starts

Additional info:

Comment 1 Paul F. Johnson 2009-08-21 08:59:01 UTC
running exchange server storage once evolution is up gives me this


(evolution-exchange-storage:3259): libedata-cal-WARNING **: e-data-cal-factory.c:528: cannot register the calendar factory OAFIID:GNOME_Evolution_Exchange_Connector_CalFactory:1.2 (not listed)

Could not register Evolution Exchange backend services.
This probably means another copy of evolution-exchange-storage
is already running.

evolution-exchange-storage is not running.

Comment 2 Milan Crha 2009-08-21 12:59:36 UTC
Please try this:
a) close evolution
b) on console: evolution --force-shutdown
c) kill all the processes returned by: ps -A | grep evo
d) kill bonobo-activation-server: ps -A | grep bonobo

when all these are not running, please run on one console:

In case the same as in comment #1 will be shown, we will try to investigate further.

Comment 3 Paul F. Johnson 2009-08-22 14:52:51 UTC
Tried it - gives exactly the same error

Comment 4 Milan Crha 2009-08-24 12:09:53 UTC
Thanks for the testing. I found it finally, it was a bug in evolution-exchange Makefile.am, fixed within this commit [1], and is part of 2.27.91, which had been released today. I've some issues building the packages at the moment, but I'll try to build them as soon as possible.

[1] http://git.gnome.org/cgit/evolution-exchange/commit/?h=gnome-2-28&id=b680cffb63debb554e1ff9a93838b4b144a25a54

Note You need to log in before you can comment on or make changes to this bug.