Bug 51860 - up2date broken? Traceback included
up2date broken? Traceback included
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
roswell
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-15 19:11 EDT by Tim Clymo
Modified: 2015-01-07 18:50 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-05 11:09:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Clymo 2001-08-15 19:11:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010725

Description of problem:
Up2date doesn't work. Here is the error message produced as soon as I click
"next" to proceed from the 7.1.93 channel ticked screen. Update agent
progress says "retrieving list of all available packages" but does nothing
at all. Only way out is to kill up2date:

Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/share/rhn/up2date/gui.py", line 352, in onChannelsPageNext
    refreshCallback = self.__refreshCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 1349, in getUpdatedPackageList
    pkgList = getAvailablePackageList(msgCallback,progressCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 610, in
getAvailablePackageList    tmp_args,tmp_method = xmlrpclib.loads(blip)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 529, in loads
    return u.close(), u.getmethodname()
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 358, in close
    raise ResponseError()
xmlrpclib.ResponseError: <xmlrpclib.ResponseError instance at 83903f0>


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rhn_register
2.up2date
3.
	

Additional info:
Comment 1 Glen Foster 2001-08-16 14:58:26 EDT
We (Red Hat) should really try to fix this before next release.
Comment 2 Mihai Ibanescu 2001-08-16 18:43:00 EDT
Tim, could you attach the contents of your /etc/sysconfig/rhn/up2date file?
Are you behind a firewall? Do you use a proxy?

Thanks.
Comment 3 Tommy McNeely 2001-08-16 21:02:15 EDT
I also get the same problem... I am behind a RH 7.1 iptables NAT firewall.. it
does NOT block anything 

# iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -o eth1 -j DNAT --to x.x.x.x

This happens on ALL redhat roswell machines I amrunnung... I finally logged into
the "beta" redhatnetwork page.. and made sure that it was "entitled" and it was.

[root@kyle root]# up2date --list

Retrieving list of all available packages...
Traceback (innermost last):
  File "/usr/sbin/up2date", line 889, in ?
    main()
  File "/usr/sbin/up2date", line 292, in main
    sys.exit(batchRun(argObj.getLong("list"), pkgNames, fullUpdate))
  File "/usr/sbin/up2date", line 708, in batchRun
    progressCallback = percentCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 1349, in getUpdatedPackageList
    pkgList = getAvailablePackageList(msgCallback,progressCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 610, in getAvailablePackageList
    tmp_args,tmp_method = xmlrpclib.loads(blip)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 529, in loads
    return u.close(), u.getmethodname()
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 358, in close
    raise ResponseError()
xmlrpclib.ResponseError: <xmlrpclib.ResponseError instance at 8395290>
[root@kyle root]# 

[root@kyle root]# cat /etc/sysconfig/rhn/up2date 
# Automatically generated Red Hat Update Agent config file, do not edit.
# Format: 1.0
noSSLServerURL[comment]=Remote server URL without SSL
noSSLServerURL=http://beta.rhns.redhat.com/XMLRPC

debug[comment]=Whether or not debugging is enabled
debug=0

noReplaceConfig[comment]=When selected, no packages that would change
configuration data are automatically installed
noReplaceConfig=1

retrieveOnly[comment]=Retrieve packages only
retrieveOnly=0

keepAfterInstall[comment]=Keep packages on disk after installation
keepAfterInstall=0

systemIdPath[comment]=Location of system id
systemIdPath=/etc/sysconfig/rhn/systemid

serverURL[comment]=Remote server URL
serverURL=https://beta.rhns.redhat.com/XMLRPC

pkgSkipList[comment]=A list of package names, optionally including wildcards, to
skip
pkgSkipList=kernel*;

adminAddress[comment]=List of e-mail addresses for update agent to communicate
with when run in batch mode
adminAddress=root@localhost;

storageDir[comment]=Where to store packages and other data when they are
retrieved
storageDir=/var/spool/up2date

fileSkipList[comment]=A list of file names, optionally including wildcards, to
skip
fileSkipList=;

removeSkipList[comment]=A list of package names, optionally including wildcards
that up2date will not remove
removeSkipList=kernel*;

enableProxy[comment]=Use a HTTP Proxy
enableProxy=0

retrieveSource[comment]=Retrieve source RPM along with binary package
retrieveSource=0

versionOverride[comment]=Override the automatically determined system version
versionOverride=

httpProxy[comment]=HTTP proxy in host:port format, e.g. squid.redhat.com:3128
httpProxy=

useGPG[comment]=Use GPG to verify package integrity
useGPG=1

noBootLoader[comment]=To disable modification of the boot loader (lilo, silo,
etc)
noBootLoader=0

networkRetries[comment]=Number of attempts to make at network connections before
giving up
networkRetries=5
[root@kyle root]#
Comment 4 Tim Clymo 2001-08-17 02:41:23 EDT
My up2date config is identical to Tommy's so I won't repeat...
I'm behind a Raptor firewall. Not configured as a proxy, but it passes https and
http transparently (and uses NAT)
Comment 5 Tommy McNeely 2001-08-20 15:24:04 EDT
[root@kyle tommy]# rpm -q up2date up2date-gnome python-xmlrpc
up2date-2.6.0-7.x.31
up2date-gnome-2.6.0-7.x.31
python-xmlrpc-1.4.7-1
[root@kyle tommy]# up2date --nox --list

For this beta release of Red Hat Linux, the up2date program has been
configured to point to a different Red Hat Network server.  This server
(beta.rhns.redhat.com) can be used to obtain updated packages for the
duration of this Red Hat Linux beta test ONLY.  After the beta test has been
completed, this Red Hat Network server will no longer be available for use.


Retrieving list of all available packages...
Traceback (innermost last):
  File "/usr/sbin/up2date", line 1017, in ?
    main()
  File "/usr/sbin/up2date", line 365, in main
    sys.exit(batchRun(argObj.getLong("list"), pkgNames, fullUpdate))
  File "/usr/sbin/up2date", line 900, in batchRun
    printCallback, percentCallback)
  File "/usr/sbin/up2date", line 813, in runInteractive
    progressCallback = percentCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 1371, in
getUpdatedPackageList
    pkgList = getAvailablePackageList(msgCallback,progressCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 638, in
getAvailablePackageList
    tmp_args,tmp_method = xmlrpclib.loads(blip)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 529, in loads
    return u.close(), u.getmethodname()
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 358, in close
    raise ResponseError()
xmlrpclib.ResponseError: <xmlrpclib.ResponseError instance at 81d9d18>
[root@kyle tommy]# 

Per Bug# 50891 this may have something to do with a transperant webcache server.
I know I am behind one that affects ALL port 80 traffic (because my VPN used to
use port 80). There is nothing I can do about it though, unless I can modify the
config file to use a diffrent port.

Tommy McNeely
Comment 6 Michael Young 2001-08-21 12:51:44 EDT
At the risk of stating the obvious, most if not all of the communications from
up2date will be on the https port of 443 (now that bug 50891 is fixed). Can you
view other https sites, for example
https://listman.redhat.com/ ?
Comment 7 Tommy McNeely 2001-08-21 14:43:46 EDT
I didn't specificlly say so.. but yes.. https sites work fine and DO NOT go
through a proxy. I spend a lot of time on https://www.securityspace.com and
"sun.net" (which won't work through a proxy very well) it is the first list
grab, the http request. 

If I cant make it work, I might just download 7.0.94 iso's and re-install.. it
(nautilus) is running slow as molasis anyways, maybe something was left in debug
mode and the upgrade will fix it? 

ACTUALLY...

It is working today.. I think it was due to the roswell-2 lockdown. Everything
seems happy now.

So is the fix the updated python-xmlrpc or the up2date packages or both (cause
my laptop is in the same boat) but it is behind nasty icky netscape proxy
servers :(

Tommy
Comment 8 Mihai Ibanescu 2001-08-21 15:02:09 EDT
If you are behind a proxy, you definitely need the new python-xmlrpc and up2date
code.
Comment 9 Tim Clymo 2001-08-21 18:00:43 EDT
Updated python-xmlrpc and up2date - same error, but slightly different line
numbers - I guess that wasn't it :-(

# rpm -qa|grep -e python-xmlrpc -e up2date
up2date-gnome-2.6.0-7.x.31
up2date-2.6.0-7.x.31
python-xmlrpc-1.4.7-1
# up2date
Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/share/rhn/up2date_client/gui.py", line 352, in onChannelsPageNext
    refreshCallback = self.__refreshCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 1371, in
getUpdatedPackageList
    pkgList = getAvailablePackageList(msgCallback,progressCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 638, in
getAvailablePackageList
    tmp_args,tmp_method = xmlrpclib.loads(blip)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 529, in loads
    return u.close(), u.getmethodname()
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 358, in close
    raise ResponseError()
xmlrpclib.ResponseError: <xmlrpclib.ResponseError instance at 8397178>
Comment 10 Damian Christey 2001-09-05 11:09:42 EDT
I am experiencing this bug as described. I believe I have the most recent
python-xmlrpc and up2date:
# rpm -q python-xmlrpc up2date
python-xmlrpc-1.4.8-3
up2date-2.6.0-7.x.31
I am not behind a proxy.  I am behind a masquerading firewall, but it is only
blocking spoofed packets.
Comment 11 Adrian Likins 2002-03-26 18:18:21 EST
These issues should be fixed with the current releases (some odd
low level proxie handling issues were the root cause, iirc. tended
to break in weird ways (ie, on setups that werent using proxies...)

Having seen any reports of similar issues in quite a while,
so I'm gonna close this out.

Note You need to log in before you can comment on or make changes to this bug.