Bug 518624 - Changing Desktop Themes in a gnome-session via FreeNX does not work
Summary: Changing Desktop Themes in a gnome-session via FreeNX does not work
Keywords:
Status: CLOSED DUPLICATE of bug 504309
Alias: None
Product: Fedora
Classification: Fedora
Component: freenx-server
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-21 10:59 UTC by Stefan Lehmann
Modified: 2009-10-24 15:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-24 15:04:47 UTC


Attachments (Terms of Use)
my gnome packages (3.85 KB, text/plain)
2009-08-21 10:59 UTC, Stefan Lehmann
no flags Details
Screencast of Bug (290.46 KB, video/x-theora+ogg)
2009-08-21 13:46 UTC, Stefan Lehmann
no flags Details
Sessionlog (4.66 KB, text/plain)
2009-08-24 08:28 UTC, Stefan Lehmann
no flags Details

Description Stefan Lehmann 2009-08-21 10:59:58 UTC
Created attachment 358226 [details]
my gnome packages

Description of problem:

When i try to change Desktop Themes with gnome-appearance-properties the selected theme is applied to the gnome-appearance-properties-Window only.

Version-Release number of selected component (if applicable):
freenx-server-0.7.3-15.fc11.x86_64


How reproducible:
* Open gnome-appearance-properties via System->Preferences->Appearance (my language setting is german so maybe the menu-entry is named different)
* Select any Desktop-Theme with color changes.

Steps to Reproduce:
1. see "How preducible"
  
Actual results:
No color/theme changes ...

Expected results:
Color change / GTK-Theme change

Additional info:

Comment 1 Stefan Lehmann 2009-08-21 13:46:51 UTC
Created attachment 358245 [details]
Screencast of Bug

Comment 2 Stefan Lehmann 2009-08-24 08:28:02 UTC
Created attachment 358423 [details]
Sessionlog

Comment 3 Axel Thimm 2009-09-02 20:04:03 UTC
What happens if you log out and in again? Is the new theme displayed?

What client are you using? There are options called "Defer screen updates" that you may need to adjust to get immediate screen updates (at the cost of bandwidth).

Comment 4 Axel Thimm 2009-09-02 22:01:10 UTC
A similar bug is bug #504309. Although there is no crash here.

Just for helping google, the attachment from the sessionlog contains:
Xlib:  extension "Generic Event Extension" missing on display ":2000.0".
Xlib:  extension "Generic Event Extension" missing on display ":2000.0".
Xlib:  extension "Generic Event Extension" missing on display ":2000.0".
Xlib:  extension "Generic Event Extension" missing on display ":2000.0".
Xlib:  extension "Generic Event Extension" missing on display ":2000.0".
Xlib:  extension "Generic Event Extension" missing on display ":2000.0".
Xlib:  extension "Generic Event Extension" missing on display ":2000.0".
Xlib:  extension "Generic Event Extension" missing on display ":2000.0".
Xlib:  extension "Generic Event Extension" missing on display ":2000.0".
Xlib:  extension "Generic Event Extension" missing on display ":2000.0".

(npviewer.bin:8028): GLib-GObject-WARNING **: cannot register existing type `PkPangoFcFontMap'

(npviewer.bin:8028): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(npviewer.bin:8028): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
Fenstermanager-Warnung:Log level 16: cannot register existing type `PkPangoFcFontMap'
Fenstermanager-Warnung:Log level 8: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(gpk-update-icon:3526): GLib-GObject-WARNING **: cannot register existing type `PkPangoFcFontMap'

(gpk-update-icon:3526): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(gpk-update-icon:3526): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
Fenstermanager-Warnung:Log level 8: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(gnome-power-manager:3544): GLib-GObject-WARNING **: cannot register existing type `PkPangoFcFontMap'

(gnome-power-manager:3544): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(gnome-power-manager:3544): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
gnome-session[3471]: GLib-GObject-WARNING: cannot register existing type `PkPangoFcFontMap'
gnome-session[3471]: GLib-GObject-CRITICAL: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed
gnome-session[3471]: GLib-GObject-CRITICAL: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(kerneloops-applet:3531): GLib-GObject-WARNING **: cannot register existing type `PkPangoFcFontMap'

(kerneloops-applet:3531): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(kerneloops-applet:3531): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(firefox:7840): GLib-GObject-WARNING **: cannot register existing type `PkPangoFcFontMap'

(firefox:7840): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(firefox:7840): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(liferea:3537): GLib-GObject-WARNING **: cannot register existing type `PkPangoFcFontMap'

(liferea:3537): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(liferea:3537): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(gnome-terminal:8060): GLib-GObject-WARNING **: cannot register existing type `PkPangoFcFontMap'

(gnome-terminal:8060): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(gnome-terminal:8060): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(tracker-applet:3541): GLib-GObject-WARNING **: cannot register existing type `PkPangoFcFontMap'

(tracker-applet:3541): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(tracker-applet:3541): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(gnome-panel:3497): GLib-GObject-WARNING **: cannot register existing type `PkPangoFcFontMap'

(gnome-panel:3497): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(gnome-panel:3497): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
Xlib:  extension "Generic Event Extension" missing on display ":2000.0".

(trackerd:3528): GLib-GIO-CRITICAL **: g_file_hash: assertion `G_IS_FILE (file)' failed
Xlib:  extension "Generic Event Extension" missing on display ":2000.0".
Xlib:  extension "Generic Event Extension" missing on display ":2000.0".
Xlib:  extension "Generic Event Extension" missing on display ":2000.0".
Xlib:  extension "Generic Event Extension" missing on display ":2000.0".

(trackerd:3528): GLib-GIO-CRITICAL **: g_file_hash: assertion `G_IS_FILE (file)' failed

(trackerd:3528): GLib-GIO-CRITICAL **: g_file_hash: assertion `G_IS_FILE (file)' failed

Comment 5 Axel Thimm 2009-10-24 15:04:47 UTC

*** This bug has been marked as a duplicate of bug 504309 ***


Note You need to log in before you can comment on or make changes to this bug.