Bug 518680 - pidgin updates break libpurple dependencies for x86_64 (but on i586 side)
Summary: pidgin updates break libpurple dependencies for x86_64 (but on i586 side)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pidgin
Version: 11
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-21 16:41 UTC by Michal Jaegermann
Modified: 2009-08-21 17:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-21 17:03:40 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2009-08-21 16:41:46 UTC
Description of problem:

Fedora 11 x86_64 repositories provide libpurple.i586 packages.  After an update to libpurple-2.6.0-1.fc11 this package aquired a dependency on libgstfarsight-0.10.so.0.  The problem is that this one is supplied by farsight2 package and only farsight2.x86_64 is available in these repos.

Solutions seem to be simple.  Either drop libpurple.i586 from x86_64 repositories (could be troublesome logistically) or add farsight2.i586 on an x86_64 side.

Version-Release number of selected component (if applicable):
libpurple-2.6.0-1.fc11

Additional info:
Curiously enough an analogous libpurple-2.6.0-1.fc10 updates do not sport libgstfarsight dependency and the issue is avoided.

Comment 1 Michal Jaegermann 2009-08-21 17:03:40 UTC
Oops!  Digging further there is farsight2-0.0.14-1.fc11.i586.rpm in x86_64 repositories.  Apparently I got into some unlucky timing with some repo.


Note You need to log in before you can comment on or make changes to this bug.