Bug 518755 - presets and parameters don't load - everything sounds like raw sinewave
Summary: presets and parameters don't load - everything sounds like raw sinewave
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: zynaddsubfx
Version: rawhide
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Anthony Green
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-22 11:37 UTC by Martin Tarenskeen
Modified: 2009-09-25 20:16 UTC (History)
4 users (show)

Fixed In Version: 2.4.0-2.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-25 20:03:46 UTC


Attachments (Terms of Use)

Description Martin Tarenskeen 2009-08-22 11:37:21 UTC
Description of problem:

1. Can not load instruments and other examples from /usr/share/zynaddsubfx/
2. I can only produce raw sinewaves, no matter what instrument I select or setting I try.


Version-Release number of selected component (if applicable):
zynaddsubfx-2.4.0-1.fc11.i386.rpm from updates-testing


How reproducible:
Always - at least on my system


Steps to Reproduce:
1. Try to load an instrument from /usr/share/zynaddsubfx/ 
2. Try to select an instrument from the presetbank
3. Or try to create a new sound yourself.
  
Actual results:
1. Error message when trying to load examples from /usr/share/zynaddsubfx
2/3. Everything sounds like a raw sinewave

Expected results:
The beautiful sounds that I got without problems so in version 2.2.1-20.fc11

Additional info:
I updates zynaddsubfx in fedora 11 with: 
   
  yum --enablerepo=updates-testing update zynaddsubfx

Comment 1 Cosmin Deaconu 2009-08-29 15:42:45 UTC
Same issue. If started from the command line, zynaddsubfx will report an mxml error (mxml: Bad control character 0x1f not allowed by XML standard!) whenever I attempt to load a patch.

Similar issue (but w/ no resolution) at http://www.kvraudio.com/forum/viewtopic.php?t=252719

I upgraded to mxml-2.6 but that didn't resolve the issue either.

Comment 2 Cosmin Deaconu 2009-08-29 16:22:35 UTC
FYI, I also tried disabling the checking for bad control characters in mxml (by editing the mxml bad characters macro) but that didn't help (although, unsurprisingly the mxml errors stopped showing up).

Comment 3 Orcan Ogetbil 2009-08-31 22:09:36 UTC
Maybe it is an issue with one of the planetccrma packages that override Fedora versions of those packages. The error message doesn't tell us much.

Everything works fine on my F-11 system with no packages from planetccrma that override Fedora packages. For instance, I use Fedora's jack.

I will try zynaddsubfx-2.4 on an F-10 box (with no planetccrma stuff) and on an old F-8 box sometime this week.

Comment 4 Cosmin Deaconu 2009-09-01 03:39:04 UTC
> Everything works fine on my F-11 system with no packages from planetccrma that
> override Fedora packages. For instance, I use Fedora's jack.

Did you enable the updates-testing repository?

The version in Fedora (2.21) works without issue but the version from updates-testing does not... 

I have nothing from the planetccrma repositories.

Comment 5 Orcan Ogetbil 2009-09-01 04:52:28 UTC
(In reply to comment #4)
> > Everything works fine on my F-11 system with no packages from planetccrma that
> > override Fedora packages. For instance, I use Fedora's jack.
> 
> Did you enable the updates-testing repository?
> 

Actually, I am the one who pushed 2.24 to the updates-testing. I am not pushing it to stable until we figure out what's going on. I wish I was able to reproduce what you guys are experiencing.

Martin uses i386. What do you use Cosmin? Also what Fedora version?

> The version in Fedora (2.21) works without issue but the version from
> updates-testing does not... 
> 
> I have nothing from the planetccrma repositories.  

Alright, thanks, good to know.

Comment 6 Cosmin Deaconu 2009-09-01 05:52:47 UTC
>Martin uses i386. What do you use Cosmin? Also what Fedora version?

cozzy@cozzy:~$ uname -a
Linux cozzy 2.6.30.5-32.fc11.i586 #1 SMP Mon Aug 17 16:21:07 EDT 2009 i686 i686 i386 GNU/Linux


Here's some gdb output in case it's helpful (I set a breakpoint at mxml_error and then select a patch from the patchlist):

---------------------------------------------------------------------------
cozzy@cozzy:~$ gdb zynaddsubfx
GNU gdb (GDB) Fedora (6.8.50.20090302-38.fc11)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i586-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
(gdb) break mxml_error
Function "mxml_error" not defined.
Make breakpoint pending on future shared library load? (y or [n]) y

Breakpoint 1 (mxml_error) pending.
(gdb) r
Starting program: /usr/bin/zynaddsubfx 
[Thread debugging using libthread_db enabled]

ZynAddSubFX - Copyright (c) 2002-2009 Nasca Octavian Paul and others
Compiled: Aug  6 2009 04:05:28
This program is free software (GNU GPL v.2 or later) and 
it comes with ABSOLUTELY NO WARRANTY.

Try 'zynaddsubfx --help' for command-line options.
Sound Buffer Size = 	256 samples
Internal latency = 	5.3 ms
ADsynth Oscil.Size = 	1024 samples
[New Thread 0xb7fd3b70 (LWP 22480)]
Detaching after fork from child process 22481.
Internal SampleRate   = 48000
Jack Output SampleRate= 44100
It is recomanded that the both samplerates to be equal.
[New Thread 0xb7399b70 (LWP 22482)]
[New Thread 0xb721fb70 (LWP 22483)]
[New Thread 0xb681eb70 (LWP 22484)]
[New Thread 0xb5cffb70 (LWP 22485)]
[Switching to Thread 0xb681eb70 (LWP 22484)]

Breakpoint 1, mxml_error (
    format=0xa97cbc "Bad control character 0x%02x not allowed by XML standard!") at mxml-private.c:41
41	{
Current language:  auto; currently c
(gdb) bt
#0  mxml_error (
    format=0xa97cbc "Bad control character 0x%02x not allowed by XML standard!") at mxml-private.c:41
#1  0x00a92864 in mxml_string_getc (p=0xb681dce0, encoding=0xb681dce0)
    at mxml-file.c:2575
#2  0x00a92e42 in mxml_load_data (top=<value optimized out>, 
    p=<value optimized out>, cb=0x804cc9c <mxml_opaque_cb@plt>, 
    getc_cb=0xa92630 <mxml_string_getc>, sax_cb=0, sax_data=0x0)
    at mxml-file.c:1523
#3  0x00a943ed in mxmlLoadString (top=0x0, s=0xb5db51d9 "\213\b", 
    cb=0x804cc9c <mxml_opaque_cb@plt>) at mxml-file.c:231
#4  0x0806c938 in XMLwrapper::loadXMLfile (this=0xb5d1be88, 
    filename="/usr/share/zynaddsubfx/banks/Arpeggios//0002-Arpeggio2.xiz")
    at XMLwrapper.cpp:286
#5  0x0806b604 in Part::loadXMLinstrument (this=0x8146530, 
    filename=0x811fd28 "/usr/share/zynaddsubfx/banks/Arpeggios//0002-Arpeggio2.xiz") at Part.cpp:1006
#6  0x080a60f0 in BankUI::process (this=0x84f8a10) at BankUI.cc:327
#7  0x080a634d in BankSlot::handle (this=0x84f75c0, event=2) at BankUI.cc:27
#8  0x00ace574 in send(int, struct Fl_Widget *, struct Fl_Window *) (
    event=<value optimized out>, to=0xb5db51d8, window=0x84d1228) at Fl.cxx:698
#9  0x00acf605 in Fl::handle (e=2, window=0x84d1228) at Fl.cxx:788
#10 0x00b1f582 in fl_handle (thisevent=<value optimized out>) at Fl_x.cxx:1019
#11 0x00b208be in do_queued_events () at Fl_x.cxx:176
#12 0x00b20cf2 in fl_wait (time_to_wait=0.039872000000000067) at Fl_x.cxx:242
#13 0x00ad021c in Fl::wait (time_to_wait=1e+20) at Fl.cxx:372
#14 0x00ad0343 in Fl::wait () at Fl.cxx:403
#15 0x080e9b05 in thread3 (arg=0x0) at main.cpp:226
#16 0x008ed935 in start_thread (arg=0xb681eb70) at pthread_create.c:297
#17 0x0082294e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
---------------------------------------------------------------------------



and here are my versions of mxml / zynaddsubfx:

----------------------------------------------------------------------
cozzy@cozzy:~$ yum info mxml zynaddsubfx
Loaded plugins: dellsysidplugin, presto, refresh-packagekit
                                                    
Installed Packages
Name       : mxml
Arch       : i586
Version    : 2.5
Release    : 3.fc11
Size       : 125 k
Repo       : installed
From repo  : fedora
Summary    : Miniature XML development library
URL        : http://www.easysw.com/~mike/mxml/
License    : LGPLv2+
Description: Mini-XML is a small XML parsing library that you can use to read
           : XML and XML-like data files in your application without requiring
           : large non-standard libraries.

Name       : zynaddsubfx
Arch       : i586
Version    : 2.4.0
Release    : 1.fc11
Size       : 2.1 M
Repo       : installed
From repo  : updates-testing
Summary    : Real-time software synthesizer
URL        : http://zynaddsubfx.sourceforge.net
License    : GPLv2+
Description: ZynAddSubFX is an open source software synthesizer capable of
           : making a countless number of instrument sounds. It is microtonal,
           : and the instruments made by it sounds like those from professional
           : keyboards. The program has effects like Reverb, Echo, Chorus,
           : Phaser...
-------------------------------------------------------------------------------

Comment 7 Martin Tarenskeen 2009-09-01 06:27:32 UTC
(In reply to comment #5)
> (In reply to comment #4)
 
> Martin uses i386. What do you use Cosmin? Also what Fedora version?

Actually I'm using i586, not i386 - I selected the wrong architecture when posting the bug in Bugzilla. But I don't think that makes any difference.

Comment 8 Orcan Ogetbil 2009-09-02 17:30:15 UTC
I tried 2.4 on F-10 and F-11 on x86_64 systems. It works. Then I noticed that both of you folks were using 32bit.

I disabled usage of some assembly code on 32bit x86 systems maybe that was the cause. Could you guys try this scratch build?

http://koji.fedoraproject.org/koji/taskinfo?taskID=1650359

Comment 9 Cosmin Deaconu 2009-09-03 03:50:03 UTC
> Could you guys try this scratch build?

Still seeing the same problem. Could the issue be w/ 32-bit mxml?

Comment 10 Martin Tarenskeen 2009-09-03 06:01:39 UTC
Same result here too.

Comment 11 Orcan Ogetbil 2009-09-05 00:20:34 UTC
The bug might be in mxml but I doubt it.

Hey folks, could you report it directly upstream at sourceforge?
   http://sourceforge.net/tracker/?group_id=62934&atid=502312

The project is active and I expect them to reply soon. They may ask you for more detailed information and since I am unable to reproduce the bug, I won't be useful as a contact.

Please refer to this bug report and post the error messages and let them know that the bug is only produced in 32bit x86.

Comment 12 Cosmin Deaconu 2009-09-06 20:15:48 UTC
So if anybody is curious, https://sourceforge.net/tracker/?func=detail&atid=502312&aid=2852148&group_id=62934 is bug report I submitted on the zynaddsubfx tracker.

Comment 13 Orcan Ogetbil 2009-09-08 18:00:12 UTC
It looks like this is fixed upstream. Thanks Cosmin for taking care of this.

I made a scratch rpm with the proposed patch. Please try it out before I push it to testing.

http://koji.fedoraproject.org/koji/taskinfo?taskID=1663026

It works on x86_64.

Comment 14 Cosmin Deaconu 2009-09-08 18:21:18 UTC
>Please try it out before I push it to testing.

It works!

Comment 15 Orcan Ogetbil 2009-09-08 21:16:40 UTC
Great! I'll push this to testing. Let it stay there for about 2 weeks. If there are no other problems we can have it then on stable.

Comment 16 Martin Tarenskeen 2009-09-09 07:03:57 UTC
Thank you. It works for me too.

Comment 17 Fedora Update System 2009-09-10 03:46:39 UTC
zynaddsubfx-2.4.0-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update zynaddsubfx'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8334

Comment 18 Fedora Update System 2009-09-10 03:49:06 UTC
zynaddsubfx-2.4.0-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update zynaddsubfx'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8358

Comment 19 Fedora Update System 2009-09-25 20:03:39 UTC
zynaddsubfx-2.4.0-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2009-09-25 20:16:13 UTC
zynaddsubfx-2.4.0-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.