Bug 518765 - Unable to connect to to Yahoo Messenger : Network Error due to invalid parameters in haze.manager
Summary: Unable to connect to to Yahoo Messenger : Network Error due to invalid parame...
Keywords:
Status: CLOSED DUPLICATE of bug 514998
Alias: None
Product: Fedora
Classification: Fedora
Component: telepathy-haze
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Gordon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-22 14:34 UTC by Mohd Izhar Firdaus Ismail
Modified: 2009-08-22 18:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-22 18:14:49 UTC
Type: ---


Attachments (Terms of Use)
patch to remove all yahoo jp parameters in haze.manager (681 bytes, patch)
2009-08-22 14:34 UTC, Mohd Izhar Firdaus Ismail
no flags Details | Diff

Description Mohd Izhar Firdaus Ismail 2009-08-22 14:34:39 UTC
Created attachment 358306 [details]
patch to remove all yahoo jp parameters in haze.manager

Description of problem:
Unable to connect to yahoo messenger through telepathy. Connection failed with Network Error

Version-Release number of selected component (if applicable):
telepathy-haze-0.3.0-1.fc11.i586

How reproducible:
Always

Steps to Reproduce:
1. Launch empathy/any telepathy client
2. create a yahoo account
3. try to connect
  
Actual results:
"Network Error"

Expected results:
Should connect to YM

Additional info:

running telepathy-haze in debugging mode shows this :

[izhar@mitsuko ~]$ HAZE_PERSIST=1 HAZE_DEBUG=all /usr/libexec/telepathy-haze 2>&1
haze-Message: [info] stun: using server
(haze:14225): haze-DEBUG: init_libpurple: libpurple 2.6.1 loaded (compiled against 2.5.5)
(haze:14225): tp-glib-DEBUG: tp_proxy_borrow_interface_by_id: 0x96fb850: org.freedesktop.DBus DBusGProxy is 0x96fb888
(haze:14225): haze-DEBUG: get_protocols: Found protocols aim, gadugadu, groupwise, icq, irc, jabber, local-xmpp, msn, myspace, qq, sametime, silc, simple, yahoo, yahoojp, zephyr
(haze:14225): haze-DEBUG: haze_connection_manager_init: Initializing (HazeConnectionManager *)0x96ee568
(haze:14225): tp-glib-DEBUG: started version 0.3.0 (telepathy-glib version 0.7.29)
(haze:14225): haze-DEBUG: _haze_cm_set_param: setting parameter account (telepathy name account)
(haze:14225): haze-DEBUG: _haze_cm_set_param: setting parameter password (telepathy name password)
(haze:14225): haze-DEBUG: _haze_cm_set_param: setting parameter server (telepathy name server)
(haze:14225): haze-DEBUG: _haze_cm_set_param: setting parameter port (telepathy name port)
(haze:14225): haze-DEBUG: _haze_cm_set_param: setting parameter xfer_host (telepathy name xfer-host)
(haze:14225): haze-DEBUG: _haze_cm_set_param: setting parameter xfer_port (telepathy name xfer-port)
(haze:14225): haze-DEBUG: _haze_cm_set_param: setting parameter room_list_locale (telepathy name room-list-locale)
(haze:14225): haze-DEBUG: _haze_cm_set_param: setting parameter ignore_invites (telepathy name ignore-invites)
(haze:14225): haze-DEBUG: _haze_cm_set_param: setting parameter local_charset (telepathy name charset)
(haze:14225): tp-glib-DEBUG: parse_parameters: unknown parameters provided: yahoojp serverjp xferjp-host

Removing yahoojp,serverjp, and xferjp-host from haze.manager as workaround works.

attached a patch

Comment 1 Peter Gordon 2009-08-22 18:14:49 UTC
Thank you for the nicely detailed bug report. However, this issue has already been reported in bug #514998, and is fixed with telepathy-haze-0.3.1-1.fc11 (FEDORA-2009-8599) in testing, now submitted for stable.

Regards.

*** This bug has been marked as a duplicate of bug 514998 ***


Note You need to log in before you can comment on or make changes to this bug.