Bug 518783 - Dell XPS420 Bluetooth adapter not recognized
Summary: Dell XPS420 Bluetooth adapter not recognized
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 11
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-22 18:56 UTC by Paul Lipps
Modified: 2009-12-14 19:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-14 19:18:57 UTC
Type: ---


Attachments (Terms of Use)
Output of lsusb (1021 bytes, text/plain)
2009-08-22 18:56 UTC, Paul Lipps
no flags Details
Output of dmesg (52.21 KB, text/plain)
2009-08-22 18:57 UTC, Paul Lipps
no flags Details
Output of dmesg after installing SoundBlaster (54.84 KB, text/plain)
2009-10-25 03:24 UTC, Paul Lipps
no flags Details
Output of lsusb after installing SoundBlaster (1.04 KB, text/plain)
2009-10-25 03:24 UTC, Paul Lipps
no flags Details

Description Paul Lipps 2009-08-22 18:56:27 UTC
Created attachment 358321 [details]
Output of lsusb

Dell XPS420 Bluetooth adapter not recognized by Fedora.

It is part of CAB-200 which I believe is a TEAC RU730. It's a 15 and 1 card reader plus bluetooth. The Bluetooth Manager for Gnome reports no bluetooth adaptors present. Oddly the adaptor has been recognized twice.

When I originally purchased the computer I removed the CAB-200 as I didn't think I had a need for it. When I decided to reinstall it, it was recognized by Fedora and I was able to pair a mouse. After rebooting it has never been recognized again until..

One other time I updated the firmware when booted from my Windows partition and after I rebooted into Fedora, it was recognized again and it worked with the mouse I paired originally. But again after rebooting it has not been recognized since.

It is recognized everytime without issue in Windows Vista and XP.

Comment 1 Paul Lipps 2009-08-22 18:57:02 UTC
Created attachment 358323 [details]
Output of dmesg

Comment 2 Paul Lipps 2009-08-22 18:58:52 UTC
It's possible Bug 512347 is related but I am not sure.

Comment 3 Bastien Nocera 2009-09-03 09:53:27 UTC
This is definitely a kernel issue. If the kernel doesn't see the Bluetooth device, then user-space can't control it.

Comment 4 Paul Lipps 2009-09-07 22:04:44 UTC
Thanks

Comment 5 Paul Lipps 2009-10-25 03:24:23 UTC
Created attachment 365997 [details]
Output of dmesg after installing SoundBlaster

Comment 6 Paul Lipps 2009-10-25 03:24:53 UTC
Created attachment 365998 [details]
Output of lsusb after installing SoundBlaster

Comment 7 Paul Lipps 2009-10-25 03:25:17 UTC
I disabled my motherboard audio device and installed a SoundBlasted Audigy 2 ZS. Since doing that, my Bluetooth module is recognized and working under Fedora 11 without issue.

Comment 8 Paul Lipps 2009-12-14 16:13:53 UTC
This is also working under Fedora 12 x86_64 as well.

Comment 9 Bastien Nocera 2009-12-14 17:14:34 UTC
The main difference between the 2 logs are the kernel version, and possibly the VBoxNetAdp module being present when it works.

Remove all the third-party kernel modules junk, and try again with your original installation, it might work.

Comment 10 Paul Lipps 2009-12-14 19:11:45 UTC
See comment 7 and 8. You can close this bug as I can no longer reproduce the issue.


Note You need to log in before you can comment on or make changes to this bug.