Bug 518838 - Sound / pulseaudio is VERY unreliable
Summary: Sound / pulseaudio is VERY unreliable
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 11
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-23 14:30 UTC by Brent R Brian
Modified: 2009-08-24 14:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-24 14:43:17 UTC


Attachments (Terms of Use)
Sound preferences dialog (25.20 KB, image/png)
2009-08-23 14:32 UTC, Brent R Brian
no flags Details
Multimedia System Selector (23.63 KB, image/png)
2009-08-23 14:32 UTC, Brent R Brian
no flags Details

Description Brent R Brian 2009-08-23 14:30:36 UTC
Description of problem:

  No sound from applications
  Multimedia selector [TEST] button, no sound
  Volume slider does nothing (not muted)
  When working, and in use, it seems to use a lot of cpu time

Version-Release number of selected component (if applicable):

  System is F11 and up to date

How reproducible:

  If I fiddle long enough, it may work until reboot

Comment 1 Brent R Brian 2009-08-23 14:32:02 UTC
Created attachment 358357 [details]
Sound preferences dialog

Comment 2 Brent R Brian 2009-08-23 14:32:38 UTC
Created attachment 358358 [details]
Multimedia System Selector

Comment 3 Brent R Brian 2009-08-23 14:34:56 UTC
# lsmod | grep snd

snd_via82xx            23464  2 
gameport               10676  1 snd_via82xx
snd_ac97_codec        100128  1 snd_via82xx
ac97_bus                1564  1 snd_ac97_codec
snd_pcm                69440  2 snd_via82xx,snd_ac97_codec
snd_timer              19396  1 snd_pcm
snd_page_alloc          8312  2 snd_via82xx,snd_pcm
snd_mpu401_uart         7120  1 snd_via82xx
snd_rawmidi            20656  1 snd_mpu401_uart
snd_seq_device          6800  1 snd_rawmidi
snd                    55108  11 snd_via82xx,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               5920  1 snd

# ps -ef | grep pul

brent     3041     1  0 10:07 ?        00:00:05 /usr/bin/pulseaudio --start --log-target=syslog
brent     3044  3041  0 10:07 ?        00:00:00 /usr/libexec/pulse/gconf-helper

Comment 4 Lennart Poettering 2009-08-24 02:34:07 UTC
"No sound from applications" does not tell me much. Do the applications think they are playing music, and you simply cannot hear anything? (i.e. playback time advancing, ...). Is your sound card properly detected and appears in pavucontrol? Have you checked if playing around with "alsamixer -c0" in a terminal helps fixing the issue? if so, which control did you have to change?

Comment 5 Brent R Brian 2009-08-24 11:06:16 UTC
Thanks for the ideas ... I need to put this on hold until I can get it to fail again, I ran the alsamixer command and the sound is working fine, but, the last boot was also after more updates ... so I don't know which fixed it at this point.

I don't feel the results mean anything at this point.

Comment 6 Lennart Poettering 2009-08-24 14:43:17 UTC
Ok, closing then. Feel free top reopen if problems reappear or you have more information.


Note You need to log in before you can comment on or make changes to this bug.