Bug 51884 - ROSWELL with ATI Radeon card will not run DRI
Summary: ROSWELL with ATI Radeon card will not run DRI
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-16 14:49 UTC by Laurence Page
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-19 23:39:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86.0.log produced by vanilla ROSWELL installation (24.07 KB, text/plain)
2001-08-16 14:55 UTC, Laurence Page
no flags Details

Description Laurence Page 2001-08-16 14:49:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.61C-SGI [en] (X11; I; IRIX 6.5 IP22)

Description of problem:
ATI Radeon cannot install the radeon kernel module.  When agpgart & radeon
modules are loaded by hand with insmod the XFree86 log says that the radeon
module has the wrong version number (1.0.0 instead of 1.1.0)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install an ATI Radeon card
2. Install RedHat Beta ROSWELL
3. try running an OpenGL program - it will be very slow.  
4. Look at /var/log/XFree86.0.log there will be errors flagged about the
radeon module
	

Actual Results:  OpenGL programs will only run slowly because DRI is
disabled

Expected Results:  They should run very fast

Additional info:

[drm] failed to load kernel module "radeon"
(II) RADEON(0): [drm] drmOpen failed
(EE) RADEON(0): [dri] DRIScreenInit failed.  Disabling DRI.

Comment 1 Laurence Page 2001-08-16 14:55:07 UTC
Created attachment 28116 [details]
XFree86.0.log produced by vanilla ROSWELL installation

Comment 2 Kwan-hong, Lee 2001-08-17 02:30:43 UTC
In Roswell's RELEASE-NOTES,

- DRI support is not included for XFree86-4.1.0. This means that
  hardware-accelerated GL will not work.


Comment 3 Mike A. Harris 2001-08-28 11:41:44 UTC
That is correct, Roswell did not have any DRI support at all.
Roswell 2 does, but Radeon support was broken.  It is fixed now in
XFree86 4.1.0-0.99.2


Note You need to log in before you can comment on or make changes to this bug.