Bug 518847 - SELinux is preventing console-kit-dae (consolekit_t) "getattr" fs_t
Summary: SELinux is preventing console-kit-dae (consolekit_t) "getattr" fs_t
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ConsoleKit
Version: 11
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: jmccann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-23 15:09 UTC by faith
Modified: 2015-01-14 23:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-24 15:31:58 UTC


Attachments (Terms of Use)

Description faith 2009-08-23 15:09:58 UTC
Description of problem:  SELinux is preventing console-kit-dae (consolekit_t) "getattr" fs_t


Version-Release number of selected component (if applicable):


How reproducible: not sure; didn't seem to keep me from doing anything at the time so I didn't stop to look at it (sorry)


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Summary:

SELinux is preventing console-kit-dae (consolekit_t) "getattr" fs_t.

Detailed Description:

SELinux denied access requested by console-kit-dae. It is not expected that this
access is required by console-kit-dae and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:consolekit_t:s0-s0:c0.c1023
Target Context                system_u:object_r:fs_t:s0
Target Objects                / [ filesystem ]
Source                        ck-collect-sess
Source Path                   <Unknown>
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages           
Target RPM Packages           filesystem-2.4.21-1.fc11
Policy RPM                    selinux-policy-3.6.12-69.fc11
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain 2.6.29.6-213.fc11.i586
                              #1 SMP Tue Jul 7 20:45:17 EDT 2009 i686 i686
Alert Count                   2
First Seen                    Sat 04 Jul 2009 03:09:22 PM EDT
Last Seen                     Sat 08 Aug 2009 04:48:52 PM EDT
Local ID                      9ea5a8ea-a84c-4997-b49b-6eaea8c2486b
Line Numbers                  

Raw Audit Messages            

node=localhost.localdomain type=AVC msg=audit(1249764532.170:3812): avc:  denied  { getattr } for  pid=11737 comm="console-kit-dae" name="/" dev=dm-0 ino=2 scontext=system_u:system_r:consolekit_t:s0-s0:c0.c1023 tcontext=system_u:object_r:fs_t:s0 tclass=filesystem

Comment 1 faith 2009-09-16 22:29:58 UTC
somebody ... anybody?  please advise if I don't need to worry about this since it hasn't generated an SELinux troubleshooting report since 8/29.  wondering if I should close this bug report, or if this still could be preventing something important since I've been having so much trouble rebooting for the past few months.  thanks

Comment 2 Daniel Walsh 2009-09-24 15:31:58 UTC
I will close it as current release, if it happens again, reopen.


Note You need to log in before you can comment on or make changes to this bug.