Bug 518864 - Gourmet crashes and won't start
Summary: Gourmet crashes and won't start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gourmet
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jef Spaleta
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-23 16:14 UTC by Mathieu Bridon
Modified: 2009-11-24 07:56 UTC (History)
3 users (show)

Fixed In Version: 0.15.0-3.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-24 07:56:55 UTC
Type: ---


Attachments (Terms of Use)

Description Mathieu Bridon 2009-08-23 16:14:39 UTC
Description of problem:
$ gourmet
/usr/lib/python2.6/site-packages/gourmet/thumbnail.py:1: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import Image, urllib, md5, os.path, os, StringIO
Traceback (most recent call last):
  File "/usr/bin/gourmet", line 13, in <module>
    from gourmet.OptionParser import *
  File "/usr/lib/python2.6/site-packages/gourmet/__init__.py", line 12, in <module>
    import convert
  File "/usr/lib/python2.6/site-packages/gourmet/convert.py", line 734, in <module>
    FRACTION_MATCHER = re.compile(NUM_AND_FRACTION_REGEXP,re.UNICODE)
  File "/usr/lib64/python2.6/re.py", line 188, in compile
    return _compile(pattern, flags)
  File "/usr/lib64/python2.6/re.py", line 236, in _compile
    raise ValueError('Cannot process flags argument with a compiled pattern')
ValueError: Cannot process flags argument with a compiled pattern

I tried to remove my ~/.gourmet folder, same thing happens.


Version-Release number of selected component (if applicable):
gourmet-0.13.4-5.fc11.noarch


How reproducible:
Always

Comment 1 Jef Spaleta 2009-08-23 16:58:52 UTC
I'm getting other errors associated pygtk.  I'm going to roll up a package for gourmet 0.15. Willing to test that out of koji?

-jef

Comment 2 Mathieu Bridon 2009-08-23 17:06:25 UTC
Sure!

Actually, I was about to build 0.15 to see if it fixed the issue and then link the spec file/srpm here so that you could update it if you wanted :P

But yeah, give me the koji link and I'll try it out. :)

Comment 3 Jef Spaleta 2009-08-23 17:12:29 UTC
O.15.0 just got released and is going to be pronounced the new stable version
in like a week according to the upstream announcement.

Downside is...this is a major UI change...its using a plugin system for some functionality. That's not a bad change..its just a big change.  I'm
definitely going to be putting it into F-12. But I'm not sure I should push
this to F-11 even if it does fix all the problems.

Give me a few minutes and I'll have F-12 and F-11 koji links.
-jef

Comment 4 Jef Spaleta 2009-08-23 18:15:47 UTC
F-11 noarch package for 0.15 can be found here.
http://koji.fedoraproject.org/koji/taskinfo?taskID=1627548

Since you are an active gourmet user, I'll be relying on your feedback concerning whether the new interface

Comment 5 Mathieu Bridon 2009-08-23 18:51:27 UTC
0.15 fixes this issue.

It correctly imported my recipes database (making a backup of it beforehand) as I guess the format had changed.

About the new interface... well, I don't see a lot of differences, except that it feels simpler and cleaner (certainly because a lot of functionalities were moved to plugins that might not be enabled by default).

So that's a big +1 from me for updating gourmet to 0.15 in F11! :)

Comment 6 Fedora Update System 2009-08-23 21:34:20 UTC
gourmet-0.15.0-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gourmet-0.15.0-2.fc11

Comment 7 Russell Harrison 2009-08-24 16:13:49 UTC
I have verified that this build fixes my issue starting gourmet

Comment 8 Fedora Update System 2009-08-25 04:42:08 UTC
gourmet-0.15.0-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gourmet'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8971

Comment 9 Fedora Update System 2009-08-27 02:11:52 UTC
gourmet-0.15.0-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gourmet'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8971

Comment 10 David Le Sage 2009-09-02 05:26:45 UTC
0.15 crashes upon launch in Fedora 11 with the following output from stderr:



Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/gourmet/plugin_loader.py", line 241, in get_module
    self._loaded = __import__(self.module)
  File "/usr/lib/python2.6/site-packages/gourmet/plugins/spellcheck/__init__.py", line 1, in <module>
    import reccard_spellcheck_plugin
  File "/usr/lib/python2.6/site-packages/gourmet/plugins/spellcheck/reccard_spellcheck_plugin.py", line 1, in <module>
    import gtk, gtkspell
ImportError: No module named gtkspell
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/gourmet/plugin_loader.py", line 92, in load_active_plugins
    self.active_plugins.extend(self.available_plugin_sets[p].plugins)
  File "/usr/lib/python2.6/site-packages/gourmet/plugin_loader.py", line 254, in __getattr__
    if attr == 'plugins': return self.get_plugins()
  File "/usr/lib/python2.6/site-packages/gourmet/plugin_loader.py", line 260, in get_plugins
    return self.get_module().plugins
AttributeError: 'NoneType' object has no attribute 'plugins'
/usr/lib/python2.6/site-packages/reportlab/pdfgen/canvas.py:17: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
Traceback (most recent call last):
  File "/usr/bin/gourmet", line 35, in <module>
    gourmet.GourmetRecipeManager.startGUI()
  File "/usr/lib/python2.6/site-packages/gourmet/GourmetRecipeManager.py", line 709, in startGUI
    r=RecGui(splash_label=splash.label)
  File "/usr/lib/python2.6/site-packages/gourmet/GourmetRecipeManager.py", line 916, in __init__
    GourmetApplication.__init__(self, splash_label=splash_label)
  File "/usr/lib/python2.6/site-packages/gourmet/GourmetRecipeManager.py", line 113, in __init__
    self.setup_recipes() # Setup recipe database
  File "/usr/lib/python2.6/site-packages/gourmet/GourmetRecipeManager.py", line 203, in setup_recipes
    self.rd = recipeManager.default_rec_manager()
  File "/usr/lib/python2.6/site-packages/gourmet/recipeManager.py", line 131, in default_rec_manager
    return get_recipe_manager(**dbargs)
  File "/usr/lib/python2.6/site-packages/gourmet/recipeManager.py", line 126, in get_recipe_manager
    return RecipeManager(**args)
  File "/usr/lib/python2.6/site-packages/gourmet/backends/db.py", line 1731, in __init__
    RecData.__init__(self,*args,**kwargs)
  File "/usr/lib/python2.6/site-packages/gourmet/backends/db.py", line 160, in __init__
    self.update_version_info(gourmet.version.version)
  File "/usr/lib/python2.6/site-packages/gourmet/backends/db.py", line 475, in update_version_info
    for ingredient in self.fetch_all(self.ingredients_table,deleted=False):
  File "/usr/lib/python2.6/site-packages/gourmet/backends/db.py", line 644, in fetch_all
    **{'order_by':make_order_by(sort_by,table)}
  File "/usr/lib/python2.6/site-packages/sqlalchemy/sql/expression.py", line 1121, in execute
    return e._execute_clauseelement(self, multiparams, params)
  File "/usr/lib/python2.6/site-packages/sqlalchemy/engine/base.py", line 1209, in _execute_clauseelement
    return connection._execute_clauseelement(elem, multiparams, params)
  File "/usr/lib/python2.6/site-packages/sqlalchemy/engine/base.py", line 874, in _execute_clauseelement
    return self.__execute_context(context)
  File "/usr/lib/python2.6/site-packages/sqlalchemy/engine/base.py", line 896, in __execute_context
    self._cursor_execute(context.cursor, context.statement, context.parameters[0], context=context)
  File "/usr/lib/python2.6/site-packages/sqlalchemy/engine/base.py", line 950, in _cursor_execute
    self._handle_dbapi_exception(e, statement, parameters, cursor, context)
  File "/usr/lib/python2.6/site-packages/sqlalchemy/engine/base.py", line 931, in _handle_dbapi_exception
    raise exc.DBAPIError.instance(statement, parameters, e, connection_invalidated=is_disconnect)
sqlalchemy.exc.OperationalError: (OperationalError) no such column: ingredients.recipe_id u'SELECT ingredients.id, ingredients.recipe_id, ingredients.refid, ingredients.unit, ingredients.amount, ingredients.rangeamount, ingredients.item, ingredients.ingkey, ingredients.optional, ingredients.shopoptional, ingredients.inggroup, ingredients.position, ingredients.deleted \nFROM ingredients \nWHERE ingredients.deleted = ?' [0]

Comment 11 Fedora Update System 2009-11-24 07:56:40 UTC
gourmet-0.15.0-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.