Bug 518878 - GATEWAY= and GATEWAYDEV= deleted in /etc/sysconfig/network
Summary: GATEWAY= and GATEWAYDEV= deleted in /etc/sysconfig/network
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-network
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-23 18:37 UTC by Gene Czarcinski
Modified: 2009-10-13 17:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-13 17:42:26 UTC


Attachments (Terms of Use)

Description Gene Czarcinski 2009-08-23 18:37:57 UTC
Description of problem:

I have a qemu-kvm guest with two NICs defined: a NAT (or bridged) interface on eth0 which needs to be the default route and a private network on eth1.  Each network has its own DHCPD and DNS server.

I cannot use NetworkManager because it does not handle default routes in any usable manner.

After setting up the interfaces with system-config-network, I then modify /etc/sysconfig/netowrk to add GATEWAY= or GATEWAYDEV= to point to my eth0 network.

Things work fine (using /etc/init.d/network to bring things up) until I use system-config-network to change something after which the GATEWAY= or GATEWAYDEV= statements are deleted from /etc/sysconfig/network and the incorrect default route (from eth1) is set.

To make matters worse, there does not appear to be any way to set the default route using system-config-network.

Version-Release number of selected component (if applicable):
Fedora 11 with current maintenance as of 8/21/2009
system-config-network-1.5.97-1.FC11

How reproducible:
everytime

Comment 1 Gene Czarcinski 2009-09-22 19:14:58 UTC
ping ...

Any chance of this being addressed???

Comment 2 Gene Czarcinski 2009-10-08 16:56:16 UTC
This continues to be a problem with F12.  How about at least an answer as to whether it will ever be addressed!

Comment 3 Gene Czarcinski 2009-10-09 12:55:43 UTC
Hello ... anyone alive out there???

I am giving up on Fedora 11 and changing this report to be against rawhide (F12).

In F12, NetworkManager uses GATEWAYDEV=xxx in /etc/sysconfig/network when a specific NIC must be specified for the default route.  When you wipe out the setting, you impact NetworkManager!

Comment 4 Gene Czarcinski 2009-10-13 17:42:26 UTC
A patch has been developed and tested which eliminates the need for using GATEWAYDEV= by NetworkManager.  I am assuming that some form of this patch will be integrated into NetworkManager and am closing this report WONTFIX.

See https://bugzilla.redhat.com/show_bug.cgi?id=528281


Note You need to log in before you can comment on or make changes to this bug.