Bug 518883 - gdb/objfiles.c:823: internal-error: qsort_cmp
Summary: gdb/objfiles.c:823: internal-error: qsort_cmp
Keywords:
Status: CLOSED DUPLICATE of bug 515434
Alias: None
Product: Fedora
Classification: Fedora
Component: gdb
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jan Kratochvil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-23 20:34 UTC by Paul W. Frields
Modified: 2009-08-25 12:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-25 12:10:28 UTC


Attachments (Terms of Use)
gdb output from attempted nautilus session (17.96 KB, text/plain)
2009-08-23 20:35 UTC, Paul W. Frields
no flags Details

Description Paul W. Frields 2009-08-23 20:34:31 UTC
gdb-6.8.50.20090818-4.fc12.x86_64

Trying to see what's going on in bug 516491, I did a 'debuginfo-install nautilus-search-tool' and when I ran 'gdb -p <pid_of_nautilus>' I ended up with the following error:

<...snip...>
../../gdb/objfiles.c:823: internal-error: qsort_cmp: Assertion `obj_section_endaddr (sect1) <= sect2_addr' failed.
A problem internal to GDB has been detected,
further debugging may prove unreliable.
Quit this debugging session? (y or n) 

I'll paste the whole output as an attachment.

Comment 1 Paul W. Frields 2009-08-23 20:35:43 UTC
Created attachment 358383 [details]
gdb output from attempted nautilus session

Comment 2 Jan Kratochvil 2009-08-25 12:10:28 UTC

*** This bug has been marked as a duplicate of bug 515434 ***


Note You need to log in before you can comment on or make changes to this bug.