Bug 518926 - XFCE4 window manager keeps forgetting workspaces' names
Summary: XFCE4 window manager keeps forgetting workspaces' names
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: xfwm4
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-24 08:26 UTC by Cong Ma
Modified: 2009-08-30 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-30 16:53:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Xfce 5699 None None None Never

Description Cong Ma 2009-08-24 08:26:44 UTC
Description of problem:
XFCE4 window manager keeps forgetting my workspaces' names.

I assigned each of the four XFCE4 workspaces a unique name (using the workspace setup program at the path /usr/bin/xfwm4-workspace-settings). If I then logout of XFCE4 and login back, the names are preserved as expected. However, if I shutdown or reboot the computer, all my custom workspace names are lost and reverted to the default names, EXCEPT the first, active workspace.


Version-Release number of selected component (if applicable):
xfwm4-4.6.1-2.fc11.i586


How reproducible:
Always.


Steps to Reproduce:
See the section `Description of problem'
1. Name the workspaces
2. Reboot
3. Login back again


Actual results:
Workspaces' names are lost.


Expected results:
They should have persisted between reboots and logins.


Additional info:
When ending an XFCE4 session, I always leave the "Save sessions" checker box un-checked, because the functionality of loading saved sessions is having a lot of glitches at best, if not totally broken. If however I do save sessions, the workspace names *are* saved too.

But since other window manager settings are persistent no matter I save sessions or not, I expect the workspace settings to be the same, which unfortunately is not. And I don't think this is a correct behavior by design: it would be more reasonable to reset *all* workspaces should there be such a feature.


Thanks for your time and patience in maintaining the package.

Comment 1 Kevin Fenzi 2009-08-24 22:56:44 UTC
I don't see any existing upstream bug on this aready. Would you be willing to file one there? 

If not, I can do so. If you're willing you may be able to provide faster info on the issue for them. 

Thanks for the bug report!

Comment 2 Cong Ma 2009-08-25 03:59:58 UTC
Done.

http://bugzilla.xfce.org/show_bug.cgi?id=5699

Comment 3 Kevin Fenzi 2009-08-25 23:20:20 UTC
Thanks! 

Would you like me to keep this bug open? Or just close it and follow things upstream? 
(I added myself to CC there to follow it).

Comment 4 Cong Ma 2009-08-30 06:57:45 UTC
Sorry for the late reply. I believe you can close this bug for now. It's not really a serious matter and I'll wait for upstream patches.

Comment 5 Kevin Fenzi 2009-08-30 16:53:52 UTC
Excellent. Thanks for reporting this... I will look at applying the fix as soon as it's landed upstream.


Note You need to log in before you can comment on or make changes to this bug.