Bug 518928 - all English text in Japanese KDE apps looks double-spaced
Summary: all English text in Japanese KDE apps looks double-spaced
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: ipa-pgothic-fonts
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F12Target 565767 565768
TreeView+ depends on / blocked
 
Reported: 2009-08-24 08:31 UTC by Jens Petersen
Modified: 2010-02-16 08:24 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 565767 565768 (view as bug list)
Environment:
Last Closed: 2009-09-29 09:05:31 UTC
Type: ---


Attachments (Terms of Use)
Screenshot-kate.png (27.07 KB, image/png)
2009-08-24 10:53 UTC, Jens Petersen
no flags Details

Description Jens Petersen 2009-08-24 08:31:31 UTC
Description of problem:
If I run KDE apps in Japanese locale on GNOME,
their text is poorly displayed with the font
looking double-spaced.

How reproducible:
every time

Steps to Reproduce:
1. Login to GNOME
2. LANG=ja_JP.UTF-8 kate
  
Actual results:
Default application text appears double-spaced.

Expected results:
Same as for English etc (no langpack installed).

Additional info:
Also seems true for F11.  I haven't tested under KDE.

Comment 1 Jens Petersen 2009-08-24 08:48:04 UTC
> (no langpack installed).

This seems irrelevant - even with kde-l10n-Japanese installed
still happens for ascii text.

Comment 2 Than Ngo 2009-08-24 08:56:21 UTC
I cannot reproduce this issue on F11. it seems your local fontconfig setting causes the problem. Could you please try with a fresh new user?

Comment 3 Jens Petersen 2009-08-24 10:53:25 UTC
Created attachment 358438 [details]
Screenshot-kate.png

Rawhide screenshot of "LANG=ja_JP.UTF-8 kate".

Comment 4 Jens Petersen 2009-08-24 12:10:55 UTC
I can reproduce with a fresh user in rawhide in KDE too,
with ipa-*gothic-fonts installed.

Comment 5 Jens Petersen 2009-08-24 12:13:37 UTC
Actually only with IPAPGothic

Comment 6 Jaroslav Reznik 2009-08-24 12:53:57 UTC
Ok,
I can reproduce it with IPA gothic fonts installed.

Comment 7 Jens Petersen 2009-09-15 00:03:22 UTC
Still see this with current rawhide.

Comment 8 Akira TAGOH 2009-09-15 05:46:13 UTC
I'm asking upstream this issue and waiting for a reply.

Comment 9 Jens Petersen 2009-09-29 05:34:55 UTC
Tomorrow's rawhide should revert to vlgothic which help with this.

Comment 10 Akira TAGOH 2009-09-29 09:05:31 UTC
This issue has been forwarded to "upstream" and there are no way of fixing that in house (apparently fontforge is a bit buggy), I'll leave this to upstream and visit again when they have a new release in the future.


Note You need to log in before you can comment on or make changes to this bug.