Bug 518928 - all English text in Japanese KDE apps looks double-spaced
all English text in Japanese KDE apps looks double-spaced
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: ipa-pgothic-fonts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
: MoveUpstream
Depends On:
Blocks: F12Target 565767 565768
  Show dependency treegraph
 
Reported: 2009-08-24 04:31 EDT by Jens Petersen
Modified: 2010-02-16 03:24 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 565767 565768 (view as bug list)
Environment:
Last Closed: 2009-09-29 05:05:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot-kate.png (27.07 KB, image/png)
2009-08-24 06:53 EDT, Jens Petersen
no flags Details

  None (edit)
Description Jens Petersen 2009-08-24 04:31:31 EDT
Description of problem:
If I run KDE apps in Japanese locale on GNOME,
their text is poorly displayed with the font
looking double-spaced.

How reproducible:
every time

Steps to Reproduce:
1. Login to GNOME
2. LANG=ja_JP.UTF-8 kate
  
Actual results:
Default application text appears double-spaced.

Expected results:
Same as for English etc (no langpack installed).

Additional info:
Also seems true for F11.  I haven't tested under KDE.
Comment 1 Jens Petersen 2009-08-24 04:48:04 EDT
> (no langpack installed).

This seems irrelevant - even with kde-l10n-Japanese installed
still happens for ascii text.
Comment 2 Ngo Than 2009-08-24 04:56:21 EDT
I cannot reproduce this issue on F11. it seems your local fontconfig setting causes the problem. Could you please try with a fresh new user?
Comment 3 Jens Petersen 2009-08-24 06:53:25 EDT
Created attachment 358438 [details]
Screenshot-kate.png

Rawhide screenshot of "LANG=ja_JP.UTF-8 kate".
Comment 4 Jens Petersen 2009-08-24 08:10:55 EDT
I can reproduce with a fresh user in rawhide in KDE too,
with ipa-*gothic-fonts installed.
Comment 5 Jens Petersen 2009-08-24 08:13:37 EDT
Actually only with IPAPGothic
Comment 6 Jaroslav Reznik 2009-08-24 08:53:57 EDT
Ok,
I can reproduce it with IPA gothic fonts installed.
Comment 7 Jens Petersen 2009-09-14 20:03:22 EDT
Still see this with current rawhide.
Comment 8 Akira TAGOH 2009-09-15 01:46:13 EDT
I'm asking upstream this issue and waiting for a reply.
Comment 9 Jens Petersen 2009-09-29 01:34:55 EDT
Tomorrow's rawhide should revert to vlgothic which help with this.
Comment 10 Akira TAGOH 2009-09-29 05:05:31 EDT
This issue has been forwarded to "upstream" and there are no way of fixing that in house (apparently fontforge is a bit buggy), I'll leave this to upstream and visit again when they have a new release in the future.

Note You need to log in before you can comment on or make changes to this bug.