Bug 51893 - Random infrequent locks on Dell Lattitude CPiA
Random infrequent locks on Dell Lattitude CPiA
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-16 12:19 EDT by Douglas Kilpatrick
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-19 13:43:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Douglas Kilpatrick 2001-08-16 12:19:43 EDT
Description of Problem:

   System (Dell Latitude CPiA) occassionally locks (could be Xserver locks
up.  No evidence that the kernel is actually locked.  Have not been able to
use SysRq keys, but do not believe the sysctl is activated.  Hard drive
activity indicates that the system is alive)

Version-Release number of selected component (if applicable):
Kernel and XFree86 from with Roswell.

How Reproducible:
not very.  Happens maybe once a day...

Sorry for the low level of usefull information.

Video card is the NeoMagic 256AV.  The video card shares hardware with the
sound card, but the sound card part is not activated.  Have not been able
to verify its just the X server that locks, so I can't count out kernel
bugs yet.
Comment 1 Douglas Kilpatrick 2001-08-16 18:21:49 EDT
Sysrq is enabled (ie, alt-sysrq should cause a sync), and I have not yet been 
able to cause a sync/umount/reboot sequence when the laptop locks.  I still 
have no idea how to reproduce this.
Comment 2 Byron Miller 2001-08-17 10:39:41 EDT
I have problems with APM shutting down the PC randomly, please see the APM &
Dell C600 bug i have created. Is this happening when you resume from apm
shutting down your monitor?  I have a problem that when i resume a few minutes
later the whole PC freezes and i have to hardboot
Comment 3 Douglas Kilpatrick 2001-08-17 11:18:16 EDT
I don't tend to suspend the system much, so I have not noticed a correlation... 
But the last time it locked I had indeed suspended it recently (to remove from
the docking station)

After reading your bug report (<a
href=http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=51494>51494</a>), I can
believe that the problems might be different symptoms
of the same bug.  Will try a newer kernel when I see it in Rawhide.  (Note:
someone might want to come up with a "rawer than rawhide" tree that's updated
daily is is flat guarenteed to not work?  Its kinda annoying to wait for two
weeks after being told that there is a fix to test it.)
Comment 4 Douglas Kilpatrick 2001-08-17 23:49:59 EDT
I can pretty offically say that its not an X problem now.  Happened this
afternoon  on a fresh reboot.  APM should not have been involved either, as I
had never suspended the machine, although the screen saver (DPMS?) had kicked in.

Machine locked hard.  Network connections timed out, so its not just the X
server.  Did not remember to try sysrq.  Possibly relevant: I was doing some
large data copies via the network.  Ethernet card was the Xircom Cardbus
ethernet+modem (xircom_cb) which appears to be kinda balky with the Roswell kernel.

If someone could change the component to "kernel"...
Comment 5 Mike A. Harris 2001-08-18 04:02:48 EDT
Reassigned bug to kernel maintainer.
Comment 6 Douglas Kilpatrick 2001-08-19 13:42:58 EDT
I caused it to happen two times in realitively quick succession.

From another computer, did a large file (~1G) transfer to the system that has
problems (catbert)
( cd /path/to/mp3collection ; tar -cf - . | ssh catbert tar -xf -)

Died pretty quickly.  Did it again, died a little later, but still died.

Sysrq sorta works.  B reboots, no activity from either S, U, or K.  Both times,
the display was not blanked.

Went back to catbert and switched from X to a text VT.  Didn't die, finished up
the transfer. (switched to file-by-file instead of tar to make recovery easier)

Changed X to not use DPMS, tried again.  It locked.  When I went back, the
screen was blanked and sysrq did not work.

Switched back to a text VT, and coppied the whole collection over again.  No
lock
So:

1) Not DPMS related.
2) Might be X related somehow. (NM256AV, sound drivers currently loaded)
3) Large network useage (Xircom Cardbus card, talking to another machine on the
same hub) might be related.
4) Sysrq sometimes partially works. (B).  Sometimes doesn't at all.  Never fully
works. (S,U)

Still no good idea what causes it.
Comment 7 Douglas Kilpatrick 2001-08-21 22:58:49 EDT
No locks today with Roswell2 kernel.  I'm gonna close this for now, and reopen 
it later if it crashes on me again.

Note You need to log in before you can comment on or make changes to this bug.