Bug 518947 - qemu does not recognize -domid option
Summary: qemu does not recognize -domid option
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-24 10:15 UTC by Aleksander Trofimowicz
Modified: 2010-03-16 17:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-26 15:15:33 UTC


Attachments (Terms of Use)
ignore -xen-domid option (523 bytes, text/plain)
2009-08-24 10:15 UTC, Aleksander Trofimowicz
no flags Details

Description Aleksander Trofimowicz 2009-08-24 10:15:20 UTC
Created attachment 358432 [details]
ignore -xen-domid option

Description of problem:
features of the qemu emulator are discovered by the way of parsing 'qemu --help' command. the current release (and in fact this is true for any release/snapshot since commit e37630ca...00417d5c, which has been in qemu-kvm tree for several months) has -xen-domid option. unfortunately libvirtd uses strstr function to find '-domid' substring, then if succeeds, adds '-domid' option to the qemu argument list and not surprisingly qemu fails to start.



Version-Release number of selected component (if applicable):
qemu-kvm head: bee37f32d47a6c04ff57d18e01cf296607e22b30
libvirt head: 777fc2e9d60844a7387355d9cef06bd25190d146


How reproducible:
always

Steps to Reproduce:
1. run any vm under qemu
  
Actual results:
fails to start


Expected results:
runs smoothly

Additional info:
i'm not interested in the peculiarities of xen-related code and don't know whether -domid and -xen-domid reflects a simple syntax change or something else. but i think this should be handled in a proper way. for the time being anyone can use a quick workaround.

Comment 1 Daniel Berrangé 2009-08-28 10:25:38 UTC
I just posted a more comprehensive patch upstream that properly handles the new option name

http://www.redhat.com/archives/libvir-list/2009-August/msg00520.html

Comment 2 Daniel Berrangé 2009-11-26 15:15:33 UTC
Fixed in 0.7.4 release


Note You need to log in before you can comment on or make changes to this bug.