Bug 519 - Trouble making TCP connections via software router
Trouble making TCP connections via software router
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
5.1
alpha Linux
high Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-18 18:07 EST by john
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-22 11:37:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description john 1998-12-18 18:07:52 EST
I have an Alpha/Linux machine connected via a Linksys 5-port
hub to a Wintel PC. The PC is connected to the phone via a
modem, and is running a Vicomsoft router.

I can successfully make TCP connections (ftp, telnet, etc)
from the Alpha to the PC, and from the PC to the Alpha.
I can also make TCP connections out to external machines
from the PC.

But whenever I try to make an external TCP connection from
the Alpha, I get one of the errors ENETUNREACH or
EHOSTUNREACH (network is unreachable, or no route to host).
This is very strange, because I can "ping" the external
address, and the procedure "gethostbyname" communicates
successfully with an external nameserver (implying that UDP
connections work).

Since I don't see how it's possible for RAW and UDP
protocols to work but not TCP, I can only assume this is a
Linux bug (or incompatibility of some kind). This view is
further supported by the fact that if I disconnect the wire
from the Alpha and plug it into another Wintel laptop, that
laptop can make TCP connections through the router just
fine. (Also, at another site, the same router running on a
Wintel PC works with both other Wintel machines and Macs.)

If it's any help, the configuration info is as follows:
PC IP address = 192.168.1.1, Alpha = 192.168.1.2, router =
192.168.1.254.

netstat -nr gives

Destination  Gateway        Genmask        Flags ... Iface
-----------  -------        -------        -----     -----
192.168.1.0  0.0.0.0        255.255.255.0    U       eth0
127.0.0.0    0.0.0.0        255.0.0.0        U       lo
0.0.0.0      192.168.1.254  0.0.0.0          UG      eth0

Any help you can give me with this problem would be much
appreciated -- if I can't get this to work, I shall have to
switch to another OS ....
Comment 1 Jeff Johnson 1998-12-22 11:37:59 EST
There are no known problems with TCP connections on alpha.
Check your hub configuration -- if necessary, assign exactly
the same IP address to the alpha as one of your known-to-work
PC's and try your experiments.

Note You need to log in before you can comment on or make changes to this bug.