Bug 51902 - Bad sound on Neomagic 256AV (Dell Latitude CPiA)
Bad sound on Neomagic 256AV (Dell Latitude CPiA)
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-16 13:47 EDT by Douglas Kilpatrick
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 13:30:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Douglas Kilpatrick 2001-08-16 13:47:04 EDT
Description of Problem:
  When configuring the sound, the .wav sample sound plays

"Hello, my name is Linus Torlva... Hello, my name is Linus"

(I may be wrong about exactly where it repeats, but the point is accurate. 
Rather than playing the whole sample, it repeats the first part)

Pretending that everything is dandy results in some really funky sound
effects as things attempt to play sounds and/or the X server just draws
stuff.

(This chip shares a memory buffer between the X server and the sound card. 
Previously, limiting the Xserver to the first 2M and letting the sound card
have the remaining 0.5M worked... IIRC, the brief time I tried RH71 on this
laptop, that didn't work either.  I suspect its a "2.4 kernel" thing.)

Version-Release number of selected component (if applicable):
Roswell from the .iso's.

How Reproducible:
Very.

Steps to Reproduce:
1.  Install roswell on a Dell CPiA laptop.
2.  Run sndconfig.
3.  Let it play the sample for the NM256 chip it finds.

Actual Results:
See above.

Expected Results:
"My name is Linus Torvalds and I pronounce Linux 'Leenux'"

Additional Information:
Comment 1 Glen Foster 2001-08-16 14:45:12 EDT
Changing component to kernel
Comment 2 Douglas Kilpatrick 2001-08-16 18:29:21 EDT
Executive summary to long amount below:
Appears that the culprit was a missing "VideoRAM 2048" line in my XF86Config 
file, but things are not quite perfect yet.



Spent a large portion of the day trying to get simultanious display on LCD and 
monitor.  Failed, but that's irrelevant.

After mucking much with X, trying to run sndconfig causes the nm256 driver to 
complain:
NeoMagic 256AV/256ZX audio driver, version 1.1p
PCI: Found IRQ 5 for device 01:00.1
NM256: This doesn't look to me like the AC97-compatible version.
       You can force the driver to load by passing in the module
       parameter:
              force_ac97 = 1

       More likely, you should be using the appropriate SB-16 or
       CS4232 driver instead.  (If your BIOS has settings for
       IRQ and/or DMA for the sound card, this is *not* the correct
       driver to use.)

(Side note: the name of the paramater is "force_load", not "force_ac97")

Rebooting, sndconfig works again, but Linus still gets cut off very early.
("Hello, my name is...Hello, my name is" is a more accurate rendition than I 
had above)

Making VERY sure that the XF86Config file limits the use of memory by the 
video card to only 2 megs, and sound mostly appears to work.  I don't know why 
Linus got cut off, but the KDE intro-song plays correctly.  There are still 
some beeps and braps that probally shouldn't be playing, but its minimal and 
not normal as opposed to the previous constant and loud.

Did the installer-created XF86Config file have the "VideoRAM 2048" line?  Are 
the occassional lockups I'm getting related to my mucking with sound and X?

Comment 3 Alan Cox 2003-06-06 13:30:15 EDT
Going over old bugs I've fixed the force_load message in the current -ac tree
and will push it into mainstream. Dunno how it got missed.

Note You need to log in before you can comment on or make changes to this bug.