Bug 51903 - RPM woes after upgrading from 3.x to 4.0.2
Summary: RPM woes after upgrading from 3.x to 4.0.2
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-16 17:59 UTC by Need Real Name
Modified: 2007-04-18 16:35 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-08-16 17:59:12 UTC


Attachments (Terms of Use)

Description Need Real Name 2001-08-16 17:59:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT; DigExt)

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start with a stock 6.2 install (everything)
2. upgrade to db3
3. rebuild rpm database
4. install rpm 4.0.2
5. forget to rebuild rpm database the second time
6. install other rpms.
7. rpm -qa or rpm --rebuilddb

Actual Results:  segfault

Expected Results:  not a segfault

Additional info:

I tried doing a rpm --rebuilddb -vv, and this completed without a 
segfault.  However, a following rpm -qa shows a list of rpms that is much 
shorter than it should be.

Other info:
RH 6.2
kernel (i was in the process of upgrading to 2.2.19-6.2.7smp when this 
happened.  I have since completed the upgrade)

Comment 1 Jeff Johnson 2001-08-17 17:36:22 UTC
This problem was fixed by reinstalling (private e-mail).


Note You need to log in before you can comment on or make changes to this bug.