Bug 519085 - Using "Add/Remove Software" with a system ethernet connection gives "No network connection available"
Summary: Using "Add/Remove Software" with a system ethernet connection gives "No netwo...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-packagekit
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 524212 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-25 01:59 UTC by Justin Clift
Modified: 2014-01-21 23:11 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-23 09:31:00 UTC


Attachments (Terms of Use)
Screenshots of error. (11.87 KB, image/png)
2009-08-25 01:59 UTC, Justin Clift
no flags Details

Description Justin Clift 2009-08-25 01:59:51 UTC
Created attachment 358513 [details]
Screenshots of error.

Description of problem:

Trying to use the "Add/Remove Software" GUI with an ethernet connection that is *not* controlled via NetWork Manager generates the error "No network connection available".

However, that's not the case.  The network connection (not Network Manager controlled) is working fine and is being used for reporting this bug.


Version-Release number of selected component (if applicable):

No idea.  Whatever is in F12 Alpha.


How reproducible:

Every time.


Steps to Reproduce:
1. Start the "Add/Remove Software GUI"
2. System -> Refresh package lists
3. Error occurs (with dialog)
  
Actual results:

Error dialog occurs.  Screenshot attached.


Expected results:

Package lists would be downloaded.


Additional info:

Comment 1 Bug Zapper 2009-11-16 11:39:27 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Richard Hughes 2010-03-23 09:31:00 UTC
non-NetworkManager support was greatly improved in F12, and it's likely the bug is now fixed. Please re-open if it's still a problem.

Comment 3 Richard Hughes 2010-03-23 09:36:12 UTC
*** Bug 524212 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.