Bug 519188 - No chance for second network interface if DHCP fails on first interface
Summary: No chance for second network interface if DHCP fails on first interface
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-25 15:13 UTC by John Reiser
Modified: 2009-10-02 00:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-02 00:59:23 UTC


Attachments (Terms of Use)
saved anaconda debug traceback (132.18 KB, text/plain)
2009-08-25 15:13 UTC, John Reiser
no flags Details
/tmp/anaconda.log (35.57 KB, text/plain)
2009-08-25 15:15 UTC, John Reiser
no flags Details
dhcp lease that *is* obtained (516 bytes, text/plain)
2009-08-25 15:18 UTC, John Reiser
no flags Details
/tmp/syslog (37.78 KB, text/plain)
2009-08-25 15:20 UTC, John Reiser
no flags Details

Description John Reiser 2009-08-25 15:13:55 UTC
Created attachment 358582 [details]
saved anaconda debug traceback

Description of problem: Attempted install of Fedora 12 alpha on 64-bit PowerPC (Apple iMac G5) fails because of an unexpected exception during DHCP negotiation.  The first interface apparently fails because of "unexpected exception" [it works for previously-installed Fedora 10 and for Mac OS X], but there chance to try the second interface is not offered.


Version-Release number of selected component (if applicable):
anaconda-12.15 on  Fedora-12-Alpha-ppc-netinst.iso

How reproducible: every time


Steps to Reproduce:
1. Download Fedora-12-Alpha-ppc-netinst.iso; burn to CD-RW.
2. Boot, proceed to network setup, accept default DHCP parameters for eth0 (wired ethernet connection)

  
Actual results: Unexpected exception; cannot proceed.  The chance to try the second interface is not offered.


Expected results: DHCP success; rest of install.


Additional info: Wired ethernet works on this machine using other OSes.  Wireless ethernet (some Broadcom chip) exists, is listed as one of the interface choices.  Installer fails if either interface is tried first.  Installer does not offer the choice to try the other interface.

Comment 1 John Reiser 2009-08-25 15:15:55 UTC
Created attachment 358583 [details]
/tmp/anaconda.log

Comment 2 John Reiser 2009-08-25 15:18:10 UTC
Created attachment 358584 [details]
dhcp lease that *is* obtained

file dhclient-5fb06bd0-0bb0-7ffb-45f1-d6edd65f3e03-eth0.lease  from /var/...

Comment 3 John Reiser 2009-08-25 15:20:22 UTC
Created attachment 358585 [details]
/tmp/syslog

syslog also shows that DHCP lease was obtained.

Comment 4 Chris Lumens 2009-08-25 15:24:46 UTC
anaconda 12.15 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/anaconda/network.py", line 769, in bringUp
    state = props.Get(isys.NM_SERVICE, "State")
  File "/usr/lib/anaconda/iw/netconfig_dialog.py", line 243, in _ok
    haveNet = self.network.bringUp()
  File "/usr/lib/anaconda/iw/netconfig_dialog.py", line 178, in run
    if self._ok():
  File "/usr/lib/anaconda/gui.py", line 1003, in enableNetwork
    ret = net.run()
  File "/usr/lib/anaconda/yuminstall.py", line 1066, in doBackendSetup
    if not anaconda.intf.enableNetwork():
  File "/usr/lib/anaconda/backend.py", line 271, in doBackendSetup
    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1201, in nextClicked
    self.anaconda.dispatch.gotoNext()
DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Comment 5 David Cantrell 2009-10-02 00:59:23 UTC
I cannot reproduce this on recent rawhide trees.  If the problem is still present, please reopen the bug and post any new debugging information.


Note You need to log in before you can comment on or make changes to this bug.