Bug 51920 - piranha-gui refuses to start
piranha-gui refuses to start
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: piranha (Show other bugs)
7.3
All Linux
medium Severity high
: ---
: ---
Assigned To: Phil Copeland
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-16 17:26 EDT by Tom "spot" Callaway
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-17 15:13:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2001-08-16 17:26:19 EDT
Description of Problem:

[root@localhost root]# service piranha-gui start
Starting piranha-gui: Syntax error on line 17 of
/etc/sysconfig/ha/conf/httpd.conf:
Cannot load /etc/sysconfig/ha/modules/mod_vhost_alias.so into server:
/etc/sysconfig/ha/modules/mod_vhost_alias.so: cannot open shared object
file: No such file or directory
                                                           [FAILED]

Version-Release number of selected component (if applicable):

piranha-0.5.5-19
How Reproducible:
Always

Steps to Reproduce:
1. /sbin/service piranha-gui start

Actual Results:

piranha-gui doesnt start, crashes as above

Expected Results:

piranha-gui starts.

Additional Information:
	
the reason this is crashing is due to the fact that the
/etc/sysconfig/ha/conf/httpd.conf file has modules with non-absolute paths,
and the "ServerRoot" directive is set to /etc/sysconfig/ha, which does not
have the modules needed to start httpd. a workaround is to set the absolute
path on all the LoadModule directives.
Comment 1 Phil Copeland 2001-08-17 07:29:31 EDT
Tom, do a cvs co of piranha and in teh directory, type 'make rpms'
-24/25 should have that one fixed

Phil
=--=
Comment 2 Glen Foster 2001-08-17 15:12:38 EDT
Changing product.
Comment 3 Glen Foster 2001-08-17 15:13:51 EDT
This defect is considered MUST-FIX for Fairfax
Comment 4 Phil Copeland 2001-08-25 13:10:19 EDT
This was a RPM spec file error, it is fixed in the current CVS as of  0.5.5-24

Closing.

Note You need to log in before you can comment on or make changes to this bug.