Bug 51921 - JadeTeX can't undump
Summary: JadeTeX can't undump
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: jadetex   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-16 21:56 UTC by rudi
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-17 14:07:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2001:167 normal SHIPPED_LIVE Updated jadetex package available 2001-12-11 05:00:00 UTC

Description rudi 2001-08-16 21:56:38 UTC
Description of Problem:
I can't get jadetex-3.6-4 to run with tetex*-1.0.7-27:

$ pdfjadetex auisg.tex
This is pdfTeX, Version 3.14159-13d (Web2C 7.3.1)
pdfjadetex: fatal: Could not undump 23694 4-byte item(s).

With tetex 1.0.7-13 there are no problems. Rebuilding the fmt
file with the following seems to be enough:

pdftex --ini --progname=pdfjadetex \&pdflatex pdfjadetex.ini

I noticed, though, that the output of pdfjadetex claims it is
based on JadeTeX 3.2 (from 2001/01/18). That's confirmed
by a quick look at /usr/share/texmf/tex/jadetex/jadetex.ltx.

Version-Release number of selected component (if applicable):
3.6-4

Comment 1 rudi 2001-08-16 23:52:26 UTC
I have created, starting from jadetex-3.6-4 and making as few
changes to the spec file as possible, a new RPM for JadeTeX
3.11 (which is now hosted at SourceForge...).

The SRPM is ~110KB. If that's too large for Bugzilla, I can
email it privately. In either case, I have no problems sending a
copy and saving you some effort.

Comment 2 Tim Waugh 2001-08-17 08:24:54 UTC
The 3.2 version number that you see is the language version: when jade creates 
output meant for processing by jadetex, it puts a version number in it.  It's 
like an API version.

Does jadetex-3.11 fix the problem you are seeing?  Upgrading to new versions 
of packages after the beta has already been made public is a little too risky, 
but if there is a bug fix for this problem that I can pick up from 3.11 then 
that is a different matter..


Comment 3 Tim Waugh 2001-08-17 08:32:00 UTC
In fact, if you could attach an example that doesn't work for you, that would 
be great.


Comment 4 rudi 2001-08-17 12:55:22 UTC
I'm sorry; I should have probably filed two separate reports for this.

The "could not undump" problems is fixed on my system by regenerating
the .fmt file, even if I just stick to 3.6-4. From my limited knowledge of TeX,
undumping is used to resume execution of the TeX interpreter in a
particular configuration, which had been previously "dumped". I don't know
whether this has necessarily anything to do with the input or if it could
be due to external factors (compiler, libraries, etc.).

I think I first updated JadeTeX, THEN tetex. There might lie the cause of my
problems, because I just found that if I remove and reinstall JadeTeX 3.6-4,
the error message is no longer there. Maybe JadeTeX' spec file needs a
trigger, so that the .fmt files are rebuilt when tetex is upgraded? I'm lucky
that I have some familiarity with TeX' arcane internals, but the average
user might be confused by a message like "could not undump" and might
have no idea that the problem is merely a side effect of how packages are
installed (if my diagnosis is correct).

The 3.11 thing is probably better left to another report.

Comment 5 Tim Waugh 2001-08-17 13:00:19 UTC
Ah, I see.  Yes, a trigger is probably the solution.


Comment 6 Tim Waugh 2001-09-18 15:08:39 UTC
Fixed in jadetex-3.11-1.



Note You need to log in before you can comment on or make changes to this bug.