Bug 519238 - rescue mode is broken severely: /bin/ls is missing
Summary: rescue mode is broken severely: /bin/ls is missing
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 12
Hardware: ppc64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Martin Sivák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-25 19:45 UTC by John Reiser
Modified: 2010-04-06 08:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-06 08:39:16 UTC
Type: ---


Attachments (Terms of Use)

Description John Reiser 2009-08-25 19:45:20 UTC
Description of problem: The rescue mode of Fedora-12-Alpha-ppc-DVD.iso is nearly unusable.  There is no /bin/ls; only "echo *" works.  'rm' is there, but invoking it gives "sh: /bin/rm: /lib/ld.so.1: bad ELF interpreter: No such file or directory".  Indeed, /lib is empty, although there is a /lib_old with many files that apparently belong in /lib.  ['ls' does not work, so getting more info is hard.]


Version-Release number of selected component (if applicable):
anaconda-12.15 on Fedora-12-Alpha-ppc-DVD.iso

How reproducible: every time


Steps to Reproduce:
1. Boot Fedora-12-Alpha-ppc-DVD on Apple iMac G5 (64-bit PowerPC) using "linux rescue" command line.
2. Do not start network interfaces; Skip mounting of target as /mnt/sysimage.
3. Try to run "ls".
  
Actual results: sh: ls: not found


Expected results: 'ls' produces a directory listing


Additional info:
   gzip -dc < mounted_DVD/ppc/ppc64/ramdisk.image.gz  |  cpio --list
shows no 'ls'.  The ppc32 version also has this symptom.

Comment 1 Bug Zapper 2009-11-16 11:41:38 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Martin Sivák 2010-04-06 08:39:16 UTC
I'm closing this as a part of my bug list cleanup, because the build processes changed a lot. Is this still an issue with current F13 builds? If it is, please reopen this bug.


Note You need to log in before you can comment on or make changes to this bug.