Bug 519251 - <Return> causes Commit of a mostly-blank bugreport
Summary: <Return> causes Commit of a mostly-blank bugreport
Keywords:
Status: CLOSED DUPLICATE of bug 637163
Alias: None
Product: Bugzilla
Classification: Community
Component: User Interface
Version: 3.6
Hardware: All
OS: Linux
low
medium vote
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact:
URL:
Whiteboard:
: 627383 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-25 20:16 UTC by John Reiser
Modified: 2013-06-24 02:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 06:04:18 UTC


Attachments (Terms of Use)

Description John Reiser 2009-08-25 20:16:53 UTC
Description of problem: When a <Return> is typed while entering text in the Summary field, then the form is activated and sent as if Commit.  So if you forget to type <Tab> (or use a click of the mouse to change fields) while entering the Summary [which is the first place for significant typing] then you have submitted a mostly-blank Bugzilla report.


Version-Release number of selected component (if applicable):
http://bugzilla.redhat.com on 2009-08-25

How reproducible: every time


Steps to Reproduce:
1. Start a New, empty bug report for product Fedora.
2. Select a Component and Version.
3. Enter text for the Summary, but type a <Return> by mistake, instead of <Tab>
  
Actual results:  A new, mostly-blank bug report (in particular, lacking any Description) is entered.


Expected results:  <Return> should not activate until all fields have been filled in.


Additional info:

Comment 1 David Lawrence 2010-01-15 16:55:58 UTC
Red Hat Bugzilla is now using version 3.4 of the Bugzilla codebase and
therefore this bug will need to be re-verified against the new release. With
the updated code this bug may no longer be relevant or may have been fixed in
the new code. Updating bug version to 3.4.

Comment 2 David Lawrence 2010-08-25 21:42:08 UTC
Red Hat has now upgraded to Bugzilla 3.6 and this bug will now be reassigned to that version. It would be helpful to the Bugzilla Development Team if this bug is verified to still be an issue with the latest version. If it is no longer an issue, then feel free to close, otherwise please comment that it is still a problem and we will try to address the issue as soon as we can.

Thanks
Bugzilla Development Team

Comment 3 John Reiser 2010-08-25 22:07:38 UTC
*** Bug 627383 has been marked as a duplicate of this bug. ***

Comment 4 John Reiser 2010-08-25 22:10:04 UTC
Yes, this bug is still active.  Version 3.6 of Bugzilla still considers <Enter> in the Summary to be interpreted as a <Commit>.  This is much too early, especially when the Description has not been modified at all (still contains only the initial field header promts.)

Comment 5 John Reiser 2012-02-20 18:32:00 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=787744#c1 is another case where jskladan notes:
    /me hates that browser sends form on Enter...

Comment 6 Simon Green 2012-06-20 06:04:18 UTC

*** This bug has been marked as a duplicate of bug 637163 ***


Note You need to log in before you can comment on or make changes to this bug.