Bug 519254 - "yum update" gives IndexError: list index out of range
Summary: "yum update" gives IndexError: list index out of range
Keywords:
Status: CLOSED DUPLICATE of bug 522259
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-25 20:32 UTC by Mads Kiilerich
Modified: 2014-01-21 23:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-13 16:21:46 UTC


Attachments (Terms of Use)

Description Mads Kiilerich 2009-08-25 20:32:39 UTC
Description of problem:

Loaded plugins: refresh-packagekit
Setting up Update Process
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 178, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 352, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 201, in doCommand
    return base.updatePkgs(extcmds)
  File "/usr/share/yum-cli/cli.py", line 608, in updatePkgs
    self.update()
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 2829, in update
    tx_return.extend(self.update(po=self.getPackageObject(new)))
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 2965, in update
    updated_pkg =  self.rpmdb.searchPkgTuple(updated)[0]
IndexError: list index out of range

Version-Release number of selected component (if applicable):

yum-3.2.23-3.fc11.noarch

Comment 1 James Antill 2009-08-26 14:51:55 UTC
Does this continue to happen, or was it a one off?

What does: "rpm -Va --nofiles --nodigest" say?


If it still happens and nothing is printed for the above, would it be possible for you to alter /usr/lib/python2.6/site-packages/yum/__init__.py and put a:

print "DBG:", updated

...at line 2964 (Ie. just before the rpmdb.searchPkgTuple() call) and then run yum with -d 8 and attach the result?

Comment 2 Mads Kiilerich 2009-08-26 15:09:00 UTC
I could reproduce it on my F11 system with
yum update --enablerepo=rawhide
but the system has been updated to F12/rawhide now and the problem probably can't be reproduced.

On an other F11 system I also can't reproduce it.

Sorry; if the stacktrace doesn't say enough you may close as WORKSFORME.

But perhaps the situation of an empty list from searchPkgTuple could be handled better - either by not crashing on it or by logging the information you ask for.

Comment 3 seth vidal 2009-10-13 16:21:46 UTC

*** This bug has been marked as a duplicate of bug 522259 ***


Note You need to log in before you can comment on or make changes to this bug.