Bug 519335 - openvrml-0.18.3-1.fc12 causes broken deps in rawhide
Summary: openvrml-0.18.3-1.fc12 causes broken deps in rawhide
Keywords:
Status: CLOSED DUPLICATE of bug 517665
Alias: None
Product: Fedora
Classification: Fedora
Component: openvrml
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Braden McDaniel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-26 08:26 UTC by Alex Lancaster
Modified: 2009-08-26 11:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-26 11:24:48 UTC


Attachments (Terms of Use)

Description Alex Lancaster 2009-08-26 08:26:04 UTC
The proximate cause of this is this change:

http://cvs.fedoraproject.org/viewvc/rpms/openvrml/devel/openvrml.spec?r1=1.67&r2=1.68

which cause the following deps which can't be fulfilled:

	openvrml-0.18.3-1.fc12.i686 requires gecko-libs(x86-32) >= 0:1.9.1
	openvrml-0.18.3-1.fc12.i686 requires java(x86-32)

(full log here: http://koji.fedoraproject.org/mash/rawhide-20090825/logs/depcheck)

Does openvrml really need the gecko-libs and java at run-time?  Normally if a program is compiled agains the java and gecko (i.e xulrunner) libraries it should include them as automatic deps.

Either way java(x86-32) won't work in the intended way.  I'm not sure what the best solution is, maybe ask on fedora-devel-list.  Either way this should get fixed ASAP as it is causing broken deps in rawhide.

Comment 1 Braden McDaniel 2009-08-26 11:24:48 UTC
gecko-libs and java are both virtual dependencies.  They are not available as automatic deps.  (And, yes, they're needed at run-time, too.)

The right way to fix this is to fix bug 517665 and bug 517666.  This has been discussed on fedora-devel; a link to the thread is in those bug reports.

*** This bug has been marked as a duplicate of bug 517665 ***

Comment 2 Alex Lancaster 2009-08-26 11:32:56 UTC
OK, so meanwhile is there any temporary workaround for the package that will fix the (currently broken) deps in rawhide, because openvrml is uninstallable as-is.

Comment 3 Braden McDaniel 2009-08-26 11:37:36 UTC
Probably not with yum; with rpm you can use --nodeps.


Note You need to log in before you can comment on or make changes to this bug.