Bug 519355 - Cluster config does not work. Ever
Summary: Cluster config does not work. Ever
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-cluster
Version: 11
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Steve Whitehouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-26 10:05 UTC by jaclax
Modified: 2009-12-17 14:04 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-17 14:04:42 UTC


Attachments (Terms of Use)

Description jaclax 2009-08-26 10:05:55 UTC
Description of problem:
No cluster configuration ever works. Has ANYBODY successfully created a working cluster? Please show a real working cluster config.

Version-Release number of selected component (if applicable):
F1

How reproducible:
Everytime. No cluster config works

Steps to Reproduce:
1. define a cluster (system-config-cluster)
2. service start cman
3. fail everytime
  
Actual results:


Expected results:


Additional info:

Comment 1 Fabio Massimo Di Nitto 2009-08-26 10:27:06 UTC
system-config-cluster has been deprecated and cannot generate valid config files for cluster as shipped in F10/F11 or newer.

This config works just fine for me. It's a bit more than what you need to start a simple cluster.

<?xml version="1.0"?>

<cluster name="fabbione" config_version="1" alias="fabbione">
  <logging debug="off"/>
  <clusternodes>
    <clusternode name="fedora11-node1" votes="1" nodeid="1">
      <fence>
        <method name="single">
          <device name="virsh_fence" port="fedora11-node1"/>
        </method>
      </fence>
    </clusternode>
    <clusternode name="fedora11-node2" votes="1" nodeid="2">
      <fence>
        <method name="single">
          <device name="virsh_fence" port="fedora11-node2"/>
        </method>
      </fence>
    </clusternode>
    <clusternode name="fedora11-node3" votes="1" nodeid="3">
      <fence>
        <method name="single">
          <device name="virsh_fence" port="fedora11-node3"/>
        </method>
      </fence>
    </clusternode>
    <clusternode name="fedora11-node4" votes="1" nodeid="4">
      <fence>
        <method name="single">
          <device name="virsh_fence" port="fedora11-node4"/>
        </method>
      </fence>
    </clusternode>
    <clusternode name="fedora11-node5" votes="1" nodeid="5">
      <fence>
        <method name="single">
          <device name="virsh_fence" port="fedora11-node5"/>
        </method>
      </fence>
    </clusternode>
    <clusternode name="fedora11-node6" votes="1" nodeid="6">
      <fence>
        <method name="single">
          <device name="virsh_fence" port="fedora11-node6"/>
        </method>
      </fence>
    </clusternode>
  </clusternodes>
  <fencedevices>
    <fencedevice name="virsh_fence" agent="fence_virsh" ipaddr="daikengo.int.fabbione.net" login="root" secure="1" identity_file="/root/.ssh/id_rsa"/>
  </fencedevices>
  <quorumd interval="1" tko="10" votes="1" label="qdisk">
   <heuristic program="ping gordian.int.fabbione.net -c1 -t1" score="1" interval="2" tko="3"/>
   <heuristic program="ping golion.int.fabbione.net -c1 -t1" score="1" interval="2" tko="3"/>
   <heuristic program="ping cerberus.int.fabbione.net -c1 -t1" score="1" interval="2" tko="3"/>
   <heuristic program="ping vultus5.int.fabbione.net -c1 -t1" score="1" interval="2" tko="3"/>
  </quorumd>
  <rm central_processing="1">
    <failoverdomains>
      <failoverdomain name="failover_domain1" ordered="0" restricted="0">
        <failoverdomainnode name="fedora11-node1" priority="1"/>
        <failoverdomainnode name="fedora11-node2" priority="1"/>
        <failoverdomainnode name="fedora11-node3" priority="1"/>
        <failoverdomainnode name="fedora11-node4" priority="1"/>
        <failoverdomainnode name="fedora11-node5" priority="1"/>
        <failoverdomainnode name="fedora11-node6" priority="1"/>
      </failoverdomain>
    </failoverdomains>
    <resources>
      <ip address="192.168.0.128" monitor_link="1"/>
    </resources>
    <service autostart="1" name="vip1" domain="failover_domain1">
      <ip ref="192.168.0.128"/>
    </service>
  </rm>
</cluster>

Comment 2 Steve Whitehouse 2009-08-26 10:28:35 UTC
Is this a dup of #473131 modulo the differing distros I wonder?

I never use the config tool as I always hand edit my cluster.conf files.

Comment 3 Steve Whitehouse 2009-08-26 10:30:18 UTC
If its known to be broken, why not remove it then?

Comment 4 Steve Whitehouse 2009-08-26 10:36:58 UTC
Reopening as there is no point keeping known broken packages which we are not intendeding to fix. We should remove the package if that is the case.

Comment 5 Steve Whitehouse 2009-08-26 10:41:34 UTC
Reassigning to myself until I can find someone better :-)


Note You need to log in before you can comment on or make changes to this bug.