Bug 519364 - Upgrade to 0.2.1 release to add many missing APIs & fix major bugs
Upgrade to 0.2.1 release to add many missing APIs & fix major bugs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Sys-Virt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Stepan Kasal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12VirtTarget
  Show dependency treegraph
 
Reported: 2009-08-26 07:04 EDT by Daniel Berrange
Modified: 2009-08-26 11:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-26 11:51:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2009-08-26 07:04:28 EDT
Description of problem:
libvirt in F12 is on version 0.6.4, but the perl-Sys-Virt release is missing many APIs from this release of libvirt. These APIs are needed in order to run the perl-Sys-Virt-TCK test suite recently added to F12. Please rebase to the release just announced

http://www.redhat.com/archives/libvir-list/2009-August/msg00478.html

Changes since 0.2.0:

 - Add all new APIs upto libvirt 0.6.4 (network interfaces,
   storage volume cloning and node device create/delete)
 - Fix off-by-1 in UUID stringification
 - Set default values for optional params.
 - Use SvOK check for potentially undefined string params
 - Export all the virError related constants
 - Fix some memory leaks in C layer
 - Remove bogus module imports from test suite



FYI, I would be happy to commit & build new versions myself - just waiting for pkgdb request to be approved.....


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Stepan Kasal 2009-08-26 11:51:54 EDT
fixed in rawhide, thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.