Bug 519439 - Network with virtual machine stops working after iptables restart.
Network with virtual machine stops working after iptables restart.
Status: CLOSED DUPLICATE of bug 227011
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
11
All Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-26 11:58 EDT by michal novacek
Modified: 2009-09-04 09:01 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-04 09:01:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description michal novacek 2009-08-26 11:58:20 EDT
Description of problem:
/etc/init.d/libvirtd doesn't reacreate rules in FORWARDING chain in case iptables has been restarted.

Version-Release number of selected component (if applicable):
fedora 11, libvirt-0.6.2-14.fc11.i586

How reproducible: always

Steps to Reproduce:
1. start libvirtd, check iptables FORWARDING rules for virtual iface
2. stop iptables and see FORWARDING rules for virtual iface gone -- correct behaviour in my
opinion
3. restart libvirtd -- no rules recreated in FORWARDING 
  
Actual results: no rules recreated after libvirtd restart 

Expected results: working network with virtual machine.
Comment 1 Mark McLoughlin 2009-09-04 09:01:38 EDT
Thanks, this is a known issue - iptables doesn't provide libvirt a way for these rules to be reloaded

*** This bug has been marked as a duplicate of bug 227011 ***

Note You need to log in before you can comment on or make changes to this bug.