Bug 519469 - Can't connect to a Windows Mobile PNA
Summary: Can't connect to a Windows Mobile PNA
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: synce
Version: 10
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-26 18:03 UTC by Martin Gregorie
Modified: 2009-09-08 13:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-04 23:19:00 UTC


Attachments (Terms of Use)
Portion of /var/log/messages showing the connect/disconnect cycle. (857 bytes, text/plain)
2009-08-26 18:03 UTC, Martin Gregorie
no flags Details

Description Martin Gregorie 2009-08-26 18:03:48 UTC
Created attachment 358748 [details]
Portion of /var/log/messages showing the connect/disconnect cycle.

Description of problem:

When I connect a Binatone X.350 PNA to a USB port the sequence in the attachment repeats in /var/messages/log until the PNA is disconnected.
minicom connects to /dev/ttyUSB0 at the appropriate point in this cycle, only to be disconnected when NetworkManager disconnects from the USB port.

At least part of the problem is that this device is being mis-recognised: it is a satnav (PNA), not a mobile phone, so it has a GPS receiver, not a mobile broadband link. I want to connect to it so that I can update its database and read/write to its SD card using a proprietary application run under WINE. However, until /dev/ttyUSB0 is stable its not possible to configure the application.

Version-Release number of selected component (if applicable):
n/a

How reproducible:

Easy - connect a WinCE based PNA to a USB port
   

Steps to Reproduce:
1. Connect any PNA that uses Microsoft WinCE.NET 5.0 to a USB 2.0 port
2. sudo tail -f /var/log/messages
3. Turn the PNA on
  
Actual results:

See above.

Expected results:

The PNA should be be recognised and a serial port, /dev/ttyUSB[0-9],
should be attached to it. This should stay in existence until the PNA is switched off.
 
Additional info:

None

Comment 1 Milos Jakubicek 2009-09-04 23:19:00 UTC
This package is dead.

Comment 2 Martin Gregorie 2009-09-05 11:42:06 UTC
The problem is still there as of about 16:00 GMT 2009-09-04. I'm still seeing exactly the same set of log messages as I reported. The problem also shows up when I connect my iPAQ 3630 with exactly the same set of log messages.

The apparent problem is that Network Manager is being invoked when a device with no mobile broadband capability is connected via USB. There are a lot of devices out there, e.g. PNAs and PDAs, that do NOT have mobile broadband capability. They need to connect too for data and software updates and/or for backing them up.

Whatever subsystem is managing this should NOT invoke Network Manager and then disconnect the serial connection when it can't find a mobile broadband connection. It should definitely NOT loop on the connect/no broadband/disconnect sequence. Instead it should leave the device connected by the /dev/ttyUSBn serial connection.
 
If 'the package is dead' refers to SynCE then I apologise for blaming an incorrect package.  

Kindly re-open this bug and fix whatever is preventing PDAs and PNAs from connecting.

Comment 3 Andreas Bierfert 2009-09-08 04:38:24 UTC
It is the wrong component indeed. To stop NM from trying to manage the device try http://www.synce.org/moin/StopNetworkManagerInterfering. If it works for you afterwards there is no real bug.

Comment 4 Martin Gregorie 2009-09-08 13:13:50 UTC
I tried tnhe SynCE fix suggested by Andras Blerfert, cutting and pasting the Fedora version from http://www.synce.org/moin/StopNetworkManagerInterfering
which sets the filename suffix and device name to rndis0.

When I created the file the log showed that nm-system-settings read the ifcfg-rndis0 and ignored:  

   'System rndis0' and its device because NM_CONTROLLED was false.

Then I connected my Binatone X.350 and turned it on, which caused the same repeating set of actions to be logged as before :

kernel: usb 5-2: new full speed USB device using uhci_hcd and address 3
kernel: usb 5-2: configuration #1 chosen from 1 choice
kernel: usb 5-2: New USB device found, idVendor=045e, idProduct=00ce
kernel: usb 5-2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
kernel: usbcore: registered new interface driver usbserial
kernel: usbserial: USB Serial support registered for generic
kernel: usbcore: registered new interface driver usbserial_generic
kernel: usbserial: USB Serial Driver core
kernel: usbserial: USB Serial support registered for PocketPC PDA
kernel: ipaq: USB PocketPC PDA driver v0.5
kernel: ipaq 5-2:1.0: PocketPC PDA converter detected
kernel: usb 5-2: PocketPC PDA converter now attached to ttyUSB0
kernel: usbcore: registered new interface driver ipaq
NetworkManager: <info>  (ttyUSB0): ignoring due to lack of mobile broadband capabilties
kernel: usb 5-2: USB disconnect, address 3
kernel: ipaq ttyUSB0: PocketPC PDA converter now disconnected from ttyUSB0
kernel: ipaq 5-2:1.0: device disconnected

At this point I turned the PNA off and changed the file and device name to use 'ttyUSB0' in place of 'rndis0'. This caused the log entries:

nm-system-settings:    ifcfg-rh: removed /etc/sysconfig/network-scripts/ifcfg-rndis0.
nm-system-settings:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-ttyUSB0 ... 
nm-system-settings:    ifcfg-rh:     read connection 'System ttyUSB0'
nm-system-settings:    ifcfg-rh: Ignoring connection 'System ttyUSB0' and its device because NM_CONTROLLED was false.
nm-system-settings:    ifcfg-rh: updating /etc/sysconfig/network-scripts/ifcfg-rndis0
nm-system-settings:    ifcfg-rh:     error: Couldn't parse file '/etc/sysconfig/network-scripts/ifcfg-rndis0'
nm-system-settings:    ifcfg-rh: removed /etc/sysconfig/network-scripts/ifcfg-rndis0.
nm-system-settings:    ifcfg-rh: updating /etc/sysconfig/network-scripts/ifcfg-ttyUSB0
nm-system-settings:    ifcfg-rh: updating /etc/sysconfig/network-scripts/ifcfg-ttyUSB0

When I turned the PNA back on id did the same as before: I got the same repeating sequence with complaints about the lack of mobile broadband.


Note You need to log in before you can comment on or make changes to this bug.