Bug 519477 - Unable to open input kickstart file in Fedora 12 Alpha
Unable to open input kickstart file in Fedora 12 Alpha
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-26 14:43 EDT by Andrew McNabb
Modified: 2009-09-02 11:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 11:42:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of tty3 (33.48 KB, image/png)
2009-08-26 14:51 EDT, Andrew McNabb
no flags Details
screenshot of tty4 (33.76 KB, image/png)
2009-08-26 14:52 EDT, Andrew McNabb
no flags Details
anaconda.log (2.65 KB, text/plain)
2009-08-26 15:00 EDT, Andrew McNabb
no flags Details
kickstart script (2.06 KB, text/plain)
2009-08-27 13:52 EDT, Andrew McNabb
no flags Details
packages file (2.18 KB, text/plain)
2009-08-27 13:53 EDT, Andrew McNabb
no flags Details

  None (edit)
Description Andrew McNabb 2009-08-26 14:43:51 EDT
I have been using PXE booting to install Fedora for several versions, and there appears to be a regression in Fedora 12 Alpha.  Anaconda is giving the error: "Unable to open input kickstart file".  Here is the "append" line from my pxelinux configuration:

append initrd=f12-x86_64/initrd.img ks=nfs:aml.cs.byu.edu:/admin/install/f12-x86_64.ks ksdevice=BOOTIF

My pxelinux configuration is identical to what worked for Fedora 11 except that I changed "11" to "12" everywhere.  I have triple-checked that the kickstart file exists exactly where it should be (side-by-side with the working f11 kickstart file).  Fedora 12 doesn't use NFSv4, does it?  I ask because NFSv4 clients use different paths than NFSv3 clients.  Other than that, I can't think of any other simple reason that this wouldn't work.  The Fedora 12 configuration is basically identical to the working Fedora 11 configuration.
Comment 1 Chris Lumens 2009-08-26 14:47:09 EDT
Can you attach screenshots from tty3 and tty4?  Perhaps we're not mounting the NFS source in time or otherwise having errors reading it.
Comment 2 Andrew McNabb 2009-08-26 14:51:28 EDT
Created attachment 358754 [details]
screenshot of tty3
Comment 3 Andrew McNabb 2009-08-26 14:52:26 EDT
Created attachment 358755 [details]
screenshot of tty4

I have attached the requested screenshots.  Unfortunately, I don't see anything particularly relevant on tty3 or tty4.
Comment 4 Andrew McNabb 2009-08-26 15:00:18 EDT
Created attachment 358756 [details]
anaconda.log

I went to tty2 and noticed that the kickstart script has been successfully downloaded to /tmp/ks.cfg.

I'm attaching the anaconda.log.  This log shows that Anaconda was able to read the url from the kickstart file.
Comment 5 Andrew McNabb 2009-08-27 13:52:27 EDT
Created attachment 358930 [details]
kickstart script

I tried to switch over to HTTP to see whether it's really a problem with NFS.  It turns out that I get the same error with either HTTP or NFS.

I then trimmed out anything from the script that was at all unusual.  We have a package list as a separate file, and I noticed that if I stop including the package file, the error seems to go away.  I'm attaching the kickstart file.  Here's the part that I removed to get rid of the error:

%pre
wget -O /tmp/packages http://aml.cs.byu.edu/install/packages
%end

%packages --ignoremissing
%include /tmp/packages
%end

As I mentioned earlier, I have used the exact same lines (and the same packages file) with Fedora 11, so this seems to be a regression.  I'll attach the packages file in case it is relevant.
Comment 6 Andrew McNabb 2009-08-27 13:53:40 EDT
Created attachment 358931 [details]
packages file
Comment 7 Chris Lumens 2009-08-27 15:44:42 EDT
Testing this issue is being blocked by a pykickstart error.  I'll do a rebuild of that package now and then I can test this out tomorrow.  Thanks for the simple, straightforward reproducer.  This should make things a lot easier.
Comment 8 Chris Lumens 2009-09-02 11:42:34 EDT
Ah, this is caused by raising a different exception than is anticipated.  This will be fixed in the next build of pykickstart (though I may need to make additional changes later in anaconda).  Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.