Bug 519478 - F12 Alpha -> no X because of segmentation fault with Nvidia NVS 160M [10de:06eb]
F12 Alpha -> no X because of segmentation fault with Nvidia NVS 160M [10de:06eb]
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-08-26 14:46 EDT by Niels Haase
Modified: 2009-08-26 17:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-26 17:56:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (11.57 KB, text/plain)
2009-08-26 14:46 EDT, Niels Haase
no flags Details
dmesg after boot into runlevel 3 (54.70 KB, text/plain)
2009-08-26 17:17 EDT, Niels Haase
no flags Details
dmesg after boot into runlevel 3 + startx (54.70 KB, text/plain)
2009-08-26 17:18 EDT, Niels Haase
no flags Details

  None (edit)
Description Niels Haase 2009-08-26 14:46:25 EDT
Created attachment 358753 [details]
Xorg.0.log

Description of problem:
Fedora 12 Alpha Live x86_64 CD fails to start X with segmentation fault.


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Boot from F12 Alpha x86_64 Live CD
2. Try to start X
3. See the segmentation fault info in file Xorg.0.log attached
  
Actual results:
No X

Expected results:
X

Additional info:
01:00.0 VGA compatible controller [0300]: nVidia Corporation Quadro NVS 160M [10de:06eb] (rev a1)
Comment 1 Ben Skeggs 2009-08-26 16:54:48 EDT
Can I have your kernel log too please (even after booting into runlevel 3 would be fine).  If this is what I'm expecting, it should be fixed already if you update to the latest rawhide kernel.
Comment 2 Niels Haase 2009-08-26 17:17:32 EDT
Created attachment 358773 [details]
dmesg after boot into runlevel 3
Comment 3 Niels Haase 2009-08-26 17:18:23 EDT
Created attachment 358774 [details]
dmesg after boot into runlevel 3 + startx
Comment 4 Niels Haase 2009-08-26 17:26:35 EDT
(In reply to comment #1)
> Can I have your kernel log too please (even after booting into runlevel 3 would
> be fine).  If this is what I'm expecting, it should be fixed already if you
> update to the latest rawhide kernel.  

Here they are. Did you mean kernel-2.6.31-0.174.rc7.git2.fc12? It is included in the rawhide boot.iso from today (20090826). Should i give it a try to boot it and see if a have X for anaconda with nouveau?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Ben Skeggs 2009-08-26 17:29:08 EDT
Yup, give that a try.  The issue should be fixed.
Comment 6 Niels Haase 2009-08-26 17:56:03 EDT
(In reply to comment #5)
> Yup, give that a try.  The issue should be fixed.  

Yeah, I gave it a try with vmlinuz & initrd.img from 20080826 rawhide mash and the problem was gone! Thanks again for you help on this Ben!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.