Bug 519496 - documented -force=full option to dvd+rw-format is unimplemented
Summary: documented -force=full option to dvd+rw-format is unimplemented
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dvd+rw-tools
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Honza Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-26 20:41 UTC by Andre Robatino
Modified: 2011-05-17 15:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-17 15:12:04 UTC


Attachments (Terms of Use)

Description Andre Robatino 2009-08-26 20:41:10 UTC
Description of problem:
"dvd+rw-format -force=full /dev/dvd" does not work (at least for already formatted DVD+RWs, haven't tested with blanks) even though this option is documented in the usage summary.

[andre@compaq-pc ~]$ dvd+rw-format -force=full /dev/dvd
* BD/DVD±RW/-RAM format utility by <appro@fy.chalmers.se>, version 7.1.
* 4.7GB DVD+RW media detected.
- unimplemented command-line option for this media.
- you have the option to re-run dvd+rw-format with:
  -lead-out  to elicit lead-out relocation for better
             DVD-ROM compatibility, data is not affected;
  -force     to enforce new format (not recommended)
             and wipe the data.

[andre@compaq-pc ~]$

From the usage summary:

[andre@compaq-pc ~]$ dvd+rw-format
* BD/DVD±RW/-RAM format utility by <appro@fy.chalmers.se>, version 7.1.
- usage: dvd+rw-format [-force[=full]] [-lead-out|-blank[=full]]
         [-ssa[=none|default|max|XXXm]] /dev/dvd
[andre@compaq-pc ~]$


Version-Release number of selected component (if applicable):
dvd+rw-tools-7.1-3.fc11

How reproducible:
always

Steps to Reproduce:
1. Take an already partially formatted DVD+RW disc.
2. Attempt to do a full format with the command
dvd+rw-format -force=full /dev/dvd
  
Actual results:
Fails with above error message.

Expected results:
Should run or at least acknowledge that the usage is documented as the usage summary shows.

Comment 1 Andre Robatino 2009-08-31 03:05:15 UTC
Just verified that issue also exists in Rawhide.  Bumping Version to rawhide.

Comment 2 Bug Zapper 2009-11-16 11:43:54 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Fedora Admin XMLRPC Client 2011-01-10 13:52:26 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Honza Horak 2011-05-17 15:12:04 UTC
Full format is not implemented only for DVD+RW and DVD+RW Double Layer (other media are supported). And there is a meaningful message ("unimplemented command-line option for this media"), so this is not a bug for me.


Note You need to log in before you can comment on or make changes to this bug.