Bug 519516 - All Internet Client Applications Cause X to Crash!
Summary: All Internet Client Applications Cause X to Crash!
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 12
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: card_GeForce2
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-26 22:07 UTC by David Le Sage
Modified: 2018-04-11 09:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-05 10:46:00 UTC


Attachments (Terms of Use)
dmesg log, as requested. (28.85 KB, text/plain)
2009-08-27 10:43 UTC, David Le Sage
no flags Details
Xorg.0.log, as requested. (47.29 KB, text/plain)
2009-08-27 10:45 UTC, David Le Sage
no flags Details
My Xorg.0.log but no crash data yet. (54.06 KB, application/octet-stream)
2009-10-29 22:07 UTC, David Le Sage
no flags Details

Description David Le Sage 2009-08-26 22:07:04 UTC
Description of problem:
User successfully connects to internet via dial-up modem. User then launches an internet client application (I successively tried Firefox, Thunderbird and Konqueror.)  Application launches, attempts to download data and, after a few seconds, causes X Windows to freeze, forcing user to reboot machine.

Version-Release number of selected component (if applicable):
Fedora 12 Alpha versions of apps.  (no yum updates)

How reproducible:
Every time. Tried it with Thunderbird, Firefox and Konqueror.  Haven't tested with "ping" yet - probably worthwhile checking.

Steps to Reproduce:
1. Undertake a fresh installation of Fedora 12 Alpha from DVD. Basic, generic installation and Konqueror.
2. Dial-in using kppp with generic modem attached to /dev/ttyUSB0.
3. Once successfully connected to ISP, launch an application, such as Thunderbird, Firefox or Konqueror.
4. After a few seconds, application and X Windows itself both freeze. 
  
Actual results:
X Windows freezes prompting user to reboot machine (or log in via SSH and kill X or whatever.)

Expected results:
Applications should function and allow user to browse web or download e-mails.

Additional info:

Comment 1 Matěj Cepl 2009-08-26 22:14:29 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 David Le Sage 2009-08-27 10:43:51 UTC
Created attachment 358838 [details]
dmesg log, as requested.

Comment 3 David Le Sage 2009-08-27 10:45:28 UTC
Created attachment 358840 [details]
Xorg.0.log, as requested.

Comment 4 David Le Sage 2009-10-22 22:04:32 UTC
I can confirm that this issue is still present in the Fedora 12 Beta.


Last night, Firefox would cause a system freeze after approximately 30 seconds, needing a reboot.  (X was completely unresponsive and I could not Ctrl-Alt-Fn to another terminal.  I did not have another machine with which to poke around via ssh, unfortunately.)



ADDITIONAL INFORMATION:
Note that I could only use web applications after using my workaround for this serious modem connection issue first:


https://bugzilla.redhat.com/show_bug.cgi?id=519515



Could the two problems be related?

Comment 5 Matěj Cepl 2009-10-26 16:53:37 UTC
(In reply to comment #4)
> bug 519515
> 
> Could the two problems be related?  

most likely not. Could you please attach to this bug your Xorg.0.log from the next reboot?

Comment 6 Matěj Cepl 2009-10-26 18:28:38 UTC
Otherwise the original bug is good to be ASSIGNED to developers.

Comment 7 David Le Sage 2009-10-26 22:22:07 UTC
Matej, I have removed the Beta from that machine (since I needed to do real work.)  I will reinstall in the next few days to obtain that log for you but I can't do it immediately.

Comment 8 David Le Sage 2009-10-29 22:07:19 UTC
Created attachment 366724 [details]
My Xorg.0.log but no crash data yet.

Matej,


I reinstalled Fedora 12 on that machine last night.  Note that I have not been able to reproduce the bug yet due to the other problem discussed above (Bugzilla 519515.)  In other words, because I could not "unlock" the modem last night because of that other problem, I could not yet try to replicate this other bug, since I need an internet connection for the web client applications to cause the X crash. (As noted originally, just launching Firefox without a web connection does not cause this X crash.)


I will try again over the weekend.  I think I know what I need to do to workaround the modem issue again.


In the meantime, here is the Xorg.0.log file for my system but note it does NOT contain the crash data yet.  I hope it can still be of use to you in terms of supplying system data.

Comment 9 Matěj Cepl 2009-11-05 17:14:30 UTC
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages (at least F12Beta, but even better if the very latest versions).

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]

Comment 10 David Le Sage 2009-11-16 03:58:55 UTC
Related?  https://bugzilla.redhat.com/show_bug.cgi?id=537674

Comment 11 Bug Zapper 2009-11-16 11:44:06 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 12 Vedran Miletić 2009-12-05 10:46:00 UTC
A month has passed, closing as insufficent data per comment #9.

On a side note, linked bug in comment #10 is a duplicate of a bug that has been fixed in errata, so this bug is also likely fixed.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.