Bug 519527 - Anaconda crashes during the step "Finding Devices"
Summary: Anaconda crashes during the step "Finding Devices"
Keywords:
Status: CLOSED DUPLICATE of bug 521033
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pyblock
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:21c5933c12048bba2...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-26 23:15 UTC by Andrea Oliveti
Modified: 2010-01-05 09:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-05 09:43:08 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (51.91 KB, text/plain)
2009-08-26 23:16 UTC, Andrea Oliveti
no flags Details

Description Andrea Oliveti 2009-08-26 23:15:55 UTC
The following was filed automatically by anaconda:
anaconda 12.15-1.fc12 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/block/__init__.py", line 198, in getRaidSets
    for rs in c.get_raidsets(disks):
  File "/usr/lib/python2.6/site-packages/block/__init__.py", line 370, in getRaidSetFromRelatedMem
    for rs in getRaidSets():
  File "/usr/lib/anaconda/storage/devicetree.py", line 1494, in handleUdevDMRaidMemberFormat
    major=major, minor=minor)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1654, in handleUdevDeviceFormat
    self.handleUdevDMRaidMemberFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1270, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1088, in addUdevPartitionDevice
    self.addUdevDevice(new_info)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1258, in addUdevDevice
    device = self.addUdevPartitionDevice(info)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1864, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 293, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 74, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1201, in nextClicked
    self.anaconda.dispatch.gotoNext()
GroupingError: group_set failed

Comment 1 Andrea Oliveti 2009-08-26 23:16:01 UTC
Created attachment 358787 [details]
Attached traceback automatically from anaconda.

Comment 2 Andrea Oliveti 2009-09-24 15:17:12 UTC
Same bug in Fedora 11 but not in Fedora 10.

Comment 3 Bug Zapper 2009-11-16 11:44:14 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Hans de Goede 2010-01-05 09:43:08 UTC

*** This bug has been marked as a duplicate of bug 521033 ***


Note You need to log in before you can comment on or make changes to this bug.