Bug 519532 - • Para-virtualized RHEL drivers seems to corrupt Windows 2008 VM’s hard drive
Summary: • Para-virtualized RHEL drivers seems to corrupt Windows 2008 VM’s hard drive
Keywords:
Status: CLOSED DUPLICATE of bug 518599
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xenpv-win
Version: 5.4
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: 5.4
Assignee: Paolo Bonzini
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-26 23:28 UTC by saul mendoza
Modified: 2010-10-07 16:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-28 07:49:45 UTC


Attachments (Terms of Use)
More descriptive steps to reproduce bug (126.35 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2009-08-26 23:30 UTC, saul mendoza
no flags Details

Description saul mendoza 2009-08-26 23:28:26 UTC
Description of problem:
After installing the para-virtualized driver on a Windows 2008 Enterprise fully virtualized VM, the VM no longer boots up. The hard drive seems to be found; however, it seems to be corrupt or missing boot files.


Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server release 5.4 
Linux 2.6.18-162.el5xen #1 SMP Tue Aug 4 16:32:26 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
Every time

Steps to Reproduce:
1.Install RHEL 5.4 RC2
2.Install Windows 2008 Enterprise as a fully virtualized guest OS
3.Install PV drivers and reboot VM Twice.
  
Actual results:
Virtual machine does not boot up.

Expected results:
Virtual machine should come up.

Additional info:

More descriptive Steps in attachments.

Comment 1 saul mendoza 2009-08-26 23:30:23 UTC
Created attachment 358789 [details]
More descriptive steps to reproduce bug

Comment 2 Paolo Bonzini 2009-08-27 08:30:46 UTC
This looks like a duplicate of bug 518599, in particular because of the 100% reproducibility and the need to reboot twice.

Are you booting from a "phy" device?

Comment 3 saul mendoza 2009-08-27 18:05:42 UTC
Yes, here is my configuration file:

name = "vm161-win2k8-fully"
uuid = "d67e647b-7ad9-e26c-e506-b9f3c5ad2822"
maxmem = 2000
memory = 2000
vcpus = 4
builder = "hvm"
kernel = "/usr/lib/xen/boot/hvmloader"
boot = "c"
pae = 1
acpi = 1
apic = 1
localtime = 1
on_poweroff = "destroy"
on_reboot = "restart"
on_crash = "restart"
device_model = "/usr/lib64/xen/bin/qemu-dm"
usb = 1
usbdevice = "tablet"
sdl = 0
vnc = 1
vncunused = 1
keymap = "en-us"
disk = [ "phy:/dev/msa2324fc-2/vm161-win2k8-fully,hda,w",",hdc:cdrom,r" ]
vif = [ "mac=00:16:36:02:cb:4b,bridge=xenbr3,script=vif-bridge" ]
parallel = "none"
serial = "pty"

This VM is booting from a drive over a FC transport. Also, are there additional PV drivers in the supplemental CD? If so are those drivers recommended?

Comment 4 Paolo Bonzini 2009-08-28 07:49:45 UTC

*** This bug has been marked as a duplicate of bug 518599 ***


Note You need to log in before you can comment on or make changes to this bug.