Bug 51954 - ghostscript race condition
Summary: ghostscript race condition
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ghostscript (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-17 14:52 UTC by Chris Jones
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-17 15:14:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Jones 2001-08-17 14:52:05 UTC
Description of Problem:
Using ghostscript to distill postscript produced by Windows/Adobe 
Postscript printer drivers, I've found that some documents cause 
ghostscript to enter some kind of race condition where it consumes 100% 
CPU without actually appearing to do anything useful.

Version-Release number of selected component (if applicable):
ghostscript-5.50-17

How Reproducible:
I can provide a document that will tickle this bug, however, I am not able 
to post it publically because it contains private information. I will be 
happy to send the document to whomever is assigned this bug.

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Chris Jones 2001-08-17 15:13:57 UTC
Having checked with our legal eagles I'm sad to report that I can't even send 
the document privately because of the UK Data Protection Act.

I'm going to play around with it and see if I can remove the private data and 
still reproduce the bug, failing that, what can I do to provide you with enough 
information to be able to investigate?

Comment 2 Crutcher Dunnavant 2001-09-25 16:03:21 UTC
This is not surprising. PostScript is a production language, and as such, is
succeptable to the halting problem. Some documents don't ever finish. A brief
example follows:


%!PS-Adobe-2.0
/loop { 1 add dup == loop } def
1 loop


Without an example document which _should_ finish, but does not, I am closing this.


Note You need to log in before you can comment on or make changes to this bug.