This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 51955 - emacs can't open files from command line
emacs can't open files from command line
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: ddskk (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-17 10:52 EDT by Ross Primrose
Modified: 2007-04-18 12:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-11 02:25:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ross Primrose 2001-08-17 10:52:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.3+)
Gecko/20010809

Description of problem:
When trying to open files with emacs from the command line ('emacs
filename') emacs reports the following error: "Cannot open load file: product"

Opening files from within a running emacs works fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run emacs from the command line with a file specified.
2.Error message received
3.
	

Actual Results:  Got error message "Cannot open load file: product" and
file not opened

Expected Results:  File should have been opened.

Additional info:
Comment 1 Trond Eivind Glomsrxd 2001-08-17 11:37:26 EDT
Try "emacs -q file" and "rpm -Vf /usr/share/emacs/site-lisp/site-start.el" - I'm
 99.9% sure this is a local problem.
Comment 2 Ross Primrose 2001-08-17 13:08:15 EDT
"emacs -q file" and "rpm -Vf /usr/share/emacs/site-lisp/site-start.el"

had no effect.  This machine is the only one I've got 7.1 running on, it's a
Dell PowerEdge 350 with 7.1 pre-installed.  Same problem with emacs-nox.  The
error message appears in the status line when emacs starts.
Comment 3 Trond Eivind Glomsrxd 2001-08-17 15:05:24 EDT
The "rpm -Vf " command gave no output? Also, what does "rpm -qi emacs" return?
And does "emacs -q --no-site-file <filename>" work?
Comment 4 Ross Primrose 2001-08-17 15:27:54 EDT
rpm -Vf did indeed give no output.

emacs -q --no-site-file does work.

rpm -qi emacs gave:

rpm -qi emacs
Name        : emacs                        Relocations: (not relocateable)
Version     : 20.7                              Vendor: Red Hat, Inc.
Release     : 34                            Build Date: Fri 16 Mar 2001 01:18:58
 PM EST
Install date: Tue 07 Aug 2001 11:47:21 AM EDT      Build Host: porky.devel.redha
t.com
Group       : Applications/Editors          Source RPM: emacs-20.7-34.src.rpm
Size        : 21711391                         License: GPL
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : The libraries needed to run the GNU Emacs text editor.
Description :
Emacs is a powerful, customizable, self-documenting, modeless text
editor. Emacs contains special code editing features, a scripting
language (elisp), and the capability to read mail, news and more
without leaving the editor.

This package includes the libraries you need to run the Emacs editor,
so you need to install this package if you intend to use Emacs.  You
also need to install the actual Emacs program package (emacs-nox or
emacs-X11).  Install emacs-nox if you are not going to use the X
Window System; install emacs-X11 if you will be using X.
Comment 5 Trond Eivind Glomsrxd 2001-08-17 15:42:10 EDT
"product" is part of semi, but nothing in emacs should try to load it... which
file tries to load product? ("grep -r product /usr/share/emacs/site-lisp/*"
should give a hint) Which rpm is that file part of?
Comment 6 Ross Primrose 2001-08-17 15:56:07 EDT
If for output from grep I'm looking for lines like
"/usr/share/emacs/site-lisp/ddskk/skk-abbrev.el:(require 'product)", There's 24
different .el files, all in /usr/share/emacs/site-lisp/ddskk/ that come up with
a (require 'product').

Comment 7 Nakai 2001-08-17 16:13:35 EDT
It's ddskk problem?
Comment 8 Trond Eivind Glomsrxd 2001-08-20 23:07:10 EDT
Seems to be a problem with half of the Japanese packages being installed, the
other one not. Why, I have no idea, but it's not an Emacs issue.

Ynakai: Can you check that the current set of Japanese lisp packages have
correct dependencies?
Comment 9 Jens Petersen 2002-03-11 02:47:09 EST
ddskk has been requiring apel for a while.

Note You need to log in before you can comment on or make changes to this bug.