Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 519618 - install hangs on 'modprobe fcoe'
Summary: install hangs on 'modprobe fcoe'
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-27 03:05 UTC by John Reiser
Modified: 2009-10-31 01:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-31 01:48:00 UTC
Type: ---


Attachments (Terms of Use)
lspci; lspci -n; lspci -v (9.85 KB, text/plain)
2009-08-27 16:53 UTC, John Reiser
no flags Details
ps axl (6.84 KB, text/plain)
2009-08-27 16:54 UTC, John Reiser
no flags Details

Description John Reiser 2009-08-27 03:05:16 UTC
+++ This bug was initially created as a clone of Bug #494390 +++
During an initial install from DVD the machine fails to make the transition to graphical mode.

Component versions:
kernel-PAE-2.6.31-0.125.4.2.rc5.git2.fc12.i686.rpm
xorg-x11-drv-intel-2.8.0-3.fc12.i686.rpm

Reproducible: every time

How to reproduce: boot Fedora-12-Alpha-i386-DVD.iso from a real DVD on Apple Mac mini i686-only with Intel 945/950 graphics.

I have verified that the problem originally reported in bug #494390 against Fedora 11 beta persists using Fedora-12-Alpha-i386-DVD.iso burned to a DVD.  Booting and selecting the first choice "Install or update..." gets a hard crash at the transition from text to graphics mode.  The screen goes black, the backlight on the display is off, and there is no response to the keyboard <Ctrl><Alt>F2 trying to get a shell on VT2.  The only option is power cycle: turn off, turn on.

Again using the Fedora 12 Alpha DVD for i386, but selecting the second choice to install with basic video driver, gets a soft hang.  The screen is blank, the backlight is on, I can get a shell on VT2.
"ps ax" suggests that "modprobe fcoe" is going nowhere in async_D+ state.  (There is no Fibre Channel over ethernet on this box.  There is an external harddrive connected via ieee1394 (400MHz FireWire.)

According to Apple "About this Mac" the hardware is:
  Model Name:	Mac mini
  Model Identifier:	Macmini1,1
  Processor Name:	Intel Core Duo   ## note: i686 only, not x86_64
  Processor Speed:	1.66 GHz
  Number Of Processors:	1
  Total Number Of Cores:	2
  L2 Cache:	2 MB
  Memory:	2 GB
  Bus Speed:	667 MHz
  Boot ROM Version:	MM11.0055.B08

Intel GMA 950:
  Chipset Model:	GMA 950
  Type:	Display
  Bus:	Built-In
  VRAM (Total):	64 MB of Shared System Memory
  Vendor:	Intel (0x8086)
  Device ID:	0x27a2
  Revision ID:	0x0003
  Displays:
1740CX:
  Resolution:	1280 x 1024 @ 60 Hz
  Depth:	32-Bit Color
  Core Image:	Hardware Accelerated
  Main Display:	Yes
  Mirror:	Off
  Online:	Yes
  Quartz Extreme:	Supported
  Rotation:	Supported

Examining the Packages directory on Fedora-12-Alpha-i386-DVD, I see:
kernel-PAE-2.6.31-0.125.4.2.rc5.git2.fc12.i686.rpm
xorg-x11-drv-intel-2.8.0-3.fc12.i686.rpm

Comment 1 Adam Williamson 2009-08-27 13:40:10 UTC
Since you're trying to boot with 'basic graphics' (i.e. vesa) the bug clearly isn't in xorg-x11-drv-intel :)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Adam Williamson 2009-08-27 13:40:37 UTC
CCing Andy in case this has implications for Anaconda also.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 John Reiser 2009-08-27 16:53:46 UTC
Created attachment 358918 [details]
lspci; lspci -n; lspci -v

Comment 4 John Reiser 2009-08-27 16:54:27 UTC
Created attachment 358919 [details]
ps axl

Comment 5 Chuck Ebbert 2009-09-01 02:30:54 UTC
Can you capture the output of alt-sysrq-t?

Comment 6 John Reiser 2009-09-01 04:55:25 UTC
(In reply to comment #5)
> Can you capture the output of alt-sysrq-t?

Perhaps.  This is an Apple Macintosh Mini, so there is no serial port for kernel serial console.  There also is no netconsole until anaconda builds that module into the install (bug # 519756.)  The keyboard has no SysRq key, but I have a USB keyboard for PC.  So I will try that next morning (PDT), and send a .jpeg photograph of the screen.

Comment 7 John Reiser 2009-09-01 13:04:11 UTC
alt-sysrq-t displays only the single line "SysRq : Show State\n" and nothing else.  Consecutive alt-sysrq-t just repeats that one line.  This is with an additional PC-103 keyboard (having SysRq key) in addtion to the Apple keyboard-plus-mouse.  There is an external ieee1394a harddrive (FireWire 400MHz.)

The soft hang "async_ D+" now appears on "modprobe raid0".  Hmmm, the external harddrive (and/or the ieee1394 interface) seems to be common to the radi0 and fcoe hangs because FireWire can be used as an ethernet device.

Boot+install (using basic video driver) with a DVD composed by me from rawhide last week (Thursday?), with kernel-PAE-2.6.31-0.180.rc7.git4.fc12.i686.rpm, succeeds.  So perhaps the original problem is no longer interesting.

Comment 8 John Reiser 2009-10-31 01:48:00 UTC
Works for me with a DVD of yesterday's rawhide (Thurs. 2009-10-29):
   xorg-x11-drv-intel-2.9.1-1.fc12.i686.rpm
   kernel-PAE-2.6.31.5-96.fc12.i686.rpm
Successful boot and graphical install from DVD on Apple Mac mini i686 with Intel GMA 950 graphics.


Note You need to log in before you can comment on or make changes to this bug.