Bug 519638 - Imported recurrent meeting not removed when deleting all occurrences
Imported recurrent meeting not removed when deleting all occurrences
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution-data-server (Show other bugs)
5.4
All Linux
high Severity medium
: rc
: ---
Assigned To: Matthew Barnes
desktop-bugs@redhat.com
: Patch
Depends On:
Blocks: 743405 1002709
  Show dependency treegraph
 
Reported: 2009-08-27 03:44 EDT by Olivier Fourdan
Modified: 2013-10-06 21:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-06 21:32:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Milan's patch from upstream bug 593023 (698 bytes, patch)
2009-08-27 03:44 EDT, Olivier Fourdan
no flags Details | Diff
Example of recurrent meeting to import (1.65 KB, text/calendar)
2009-08-27 03:46 EDT, Olivier Fourdan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 593023 None None None Never

  None (edit)
Description Olivier Fourdan 2009-08-27 03:44:35 EDT
Created attachment 358820 [details]
Milan's patch from upstream bug 593023

Description of problem:

Detached or imported meeting remain visible after deletion

Version-Release number of selected component (if applicable):

evolution-data-server-1.12.3-18 (but the problem is also current upstream)

How reproducible:

100% reproducible

Steps to Reproduce:
1. Create a recurrent meeting in Evolution
2. Save that meeting in an ics file
3. Reimport the meeting
4. Delete the meeting with "Delete All Occurrences"

Actual results:

The meeting remains visible and accessible in the calendar.

Expected results:

The meeting is removed from the calendar. 

Additional info:

The meeting is removed internally though, as switching to another view
back and forth will not display the meeting again.

The problem might be related to the export/import as the other occurrences of
the meeting are lost after reimporting the meeting.

Milan has attached a patch for e-d-s in b.g.o 593023 that fixes the issue.
Comment 1 Olivier Fourdan 2009-08-27 03:46:58 EDT
Created attachment 358821 [details]
Example of recurrent meeting to import

Just an example of meeting to import to reproduce the issue.
Comment 5 RHEL Product and Program Management 2009-11-06 14:19:29 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 8 RHEL Product and Program Management 2010-08-09 15:38:15 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 10 RHEL Product and Program Management 2011-05-31 11:11:19 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 12 RHEL Product and Program Management 2012-06-11 21:27:20 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 15 Andrius Benokraitis 2013-10-06 21:32:25 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 5, and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.

Note You need to log in before you can comment on or make changes to this bug.