Bug 51964 - nfs-utils-0.3.1-0.6.x.1: mount failed in kickstart; nfs version 3 problem
nfs-utils-0.3.1-0.6.x.1: mount failed in kickstart; nfs version 3 problem
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
6.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-17 11:35 EDT by Arnoud Witt
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 11:54:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arnoud Witt 2001-08-17 11:35:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT; DigExt)

Description of problem:
When I try kickstart install from a RH 6.2 install server with 
kernel-2.2.19-6.2.7 and nfs-utils-0.3.1-0.6.x.1 installed, using 
kickstart floppies of different versions (6.2, 7.0, and 7.1) mount
fails when using the 7.0 version. 
During the post-install part of the 7.1 install, it takes exactly 5 
minutes for mounting to succeed. When I use the nolock mount-option 
in de post-install part, there is no delay.

Solution to the above problems seems:
On the install-server (RH 6.2, kernel-2.2.19-6.2.7, 
nfs-utils-0.3.1-0.6.x.1) I changed the script /etc/rc.d/init.d/nfs by 
adding the line

RPCMOUNTOPTS="--no-nfs-version 3"

after the checks for kernelversion and release. With this I forced 
use of NFS version less than 3 in all cases.

So to my opinion NFSv3 is not handled properly by rpc.mountd from 
nfs-utils-0.3.1-0.6.x.1

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from a bootnet.img floppy
2. At Boot: type: linux ks=nfs:install-server:/kickstart/<version>/ks.cfg
3. 
	

Actual Results:  Mount failed

Expected Results:  Mount succeeded

Additional info:
Comment 1 Pete Zaitcev 2004-04-19 11:54:58 EDT
I'm sorry to report, this fell over the horizon due to
manpower constraints, closing.

Note You need to log in before you can comment on or make changes to this bug.