Bug 519654 - kdebase-workspace hijacks the gtk policykit authentication dialog
Summary: kdebase-workspace hijacks the gtk policykit authentication dialog
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase-workspace   
(Show other bugs)
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 519495 520584 (view as bug list)
Depends On: 484945
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-27 10:21 UTC by Julian Sikorski
Modified: 2009-09-15 07:39 UTC (History)
11 users (show)

Fixed In Version: 1.2.1-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-15 07:38:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Julian Sikorski 2009-08-27 10:21:00 UTC
Description of problem:
Since the upgrade to KDE 4.3.0, when the policykit authentication dialog is invoked (e.g. by virt-manager), a qt one appears. Removing kdebase-workspace and -libs solves the problem.

Version-Release number of selected component (if applicable):
kdebase-workspace-4.3.0-9.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. install kdebase-workspace
2. start virt-manager
3. connect
  
Actual results:
a qt authentication window appears

Expected results:
a gtk authentication window appears. It did so before, virt-manager is a gtk app and I'm running a gnome desktop.

Comment 1 Rex Dieter 2009-08-27 12:49:30 UTC
yeah, unfortunately, dbus has no way to prefer one service provider over another, see bug #484945

*** This bug has been marked as a duplicate of bug 484945 ***

Comment 2 Rex Dieter 2009-08-27 13:07:04 UTC
Another option is to keep PolicyKit-kde split out, and add
Requires:  PolicyKit-authentication-agent

This would help address yum's sometimes inability to process
Obsoletes: PolicyKit-kde
on upgrade as well.

Comment 3 Jaroslav Reznik 2009-09-01 09:56:54 UTC
*** Bug 520584 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2009-09-06 13:06:05 UTC
akonadi-1.2.1-1.fc11,kdeaccessibility-4.3.1-1.fc11,kdeadmin-4.3.1-1.fc11,kdeartwork-4.3.1-1.fc11,kdebase-4.3.1-2.fc11,kdebase-runtime-4.3.1-1.fc11,kdebase-workspace-4.3.1-1.fc11,kdebindings-4.3.1-3.fc11,kdeedu-4.3.1-1.fc11,kdegames-4.3.1-1.fc11,kdegraphics-4.3.1-1.fc11,kdelibs-4.3.1-3.fc11,kdelibs-experimental-4.3.1-1.fc11,kdemultimedia-4.3.1-1.fc11,kdenetwork-4.3.1-1.fc11,kdepim-4.3.1-1.fc11,kdepim-runtime-4.3.1-1.fc11,kdepimlibs-4.3.1-1.fc11,kdeplasma-addons-4.3.1-1.fc11,kdesdk-4.3.1-1.fc11,kdetoys-4.3.1-1.fc11,kdeutils-4.3.1-1.fc11,kde-l10n-4.3.1-2.fc11,oxygen-icon-theme-4.3.1-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/akonadi-1.2.1-1.fc11,kdeaccessibility-4.3.1-1.fc11,kdeadmin-4.3.1-1.fc11,kdeartwork-4.3.1-1.fc11,kdebase-4.3.1-2.fc11,kdebase-runtime-4.3.1-1.fc11,kdebase-workspace-4.3.1-1.fc11,kdebindings-4.3.1-3.fc11,kdeedu-4.3.1-1.fc11,kdegames-4.3.1-1.fc11,kdegraphics-4.3.1-1.fc11,kdelibs-4.3.1-3.fc11,kdelibs-experimental-4.3.1-1.fc11,kdemultimedia-4.3.1-1.fc11,kdenetwork-4.3.1-1.fc11,kdepim-4.3.1-1.fc11,kdepim-runtime-4.3.1-1.fc11,kdepimlibs-4.3.1-1.fc11,kdeplasma-addons-4.3.1-1.fc11,kdesdk-4.3.1-1.fc11,kdetoys-4.3.1-1.fc11,kdeutils-4.3.1-1.fc11,kde-l10n-4.3.1-2.fc11,oxygen-icon-theme-4.3.1-1.fc11

Comment 5 Fedora Update System 2009-09-06 13:08:18 UTC
akonadi-1.2.1-1.fc10,kdeaccessibility-4.3.1-1.fc10,kdeadmin-4.3.1-1.fc10,kdeartwork-4.3.1-1.fc10,kdebase-4.3.1-2.fc10,kdebase-runtime-4.3.1-1.fc10,kdebase-workspace-4.3.1-1.fc10,kdebindings-4.3.1-3.fc10,kdeedu-4.3.1-1.fc10,kdegames-4.3.1-1.fc10,kdegraphics-4.3.1-1.fc10,kdelibs-4.3.1-3.fc10,kdelibs-experimental-4.3.1-1.fc10,kdemultimedia-4.3.1-1.fc10,kdenetwork-4.3.1-1.fc10,kdepim-4.3.1-1.fc10,kdepim-runtime-4.3.1-1.fc10,kdepimlibs-4.3.1-1.fc10,kdeplasma-addons-4.3.1-1.fc10,kdesdk-4.3.1-1.fc10,kdetoys-4.3.1-1.fc10,kdeutils-4.3.1-1.fc10,kde-l10n-4.3.1-2.fc10,oxygen-icon-theme-4.3.1-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/akonadi-1.2.1-1.fc10,kdeaccessibility-4.3.1-1.fc10,kdeadmin-4.3.1-1.fc10,kdeartwork-4.3.1-1.fc10,kdebase-4.3.1-2.fc10,kdebase-runtime-4.3.1-1.fc10,kdebase-workspace-4.3.1-1.fc10,kdebindings-4.3.1-3.fc10,kdeedu-4.3.1-1.fc10,kdegames-4.3.1-1.fc10,kdegraphics-4.3.1-1.fc10,kdelibs-4.3.1-3.fc10,kdelibs-experimental-4.3.1-1.fc10,kdemultimedia-4.3.1-1.fc10,kdenetwork-4.3.1-1.fc10,kdepim-4.3.1-1.fc10,kdepim-runtime-4.3.1-1.fc10,kdepimlibs-4.3.1-1.fc10,kdeplasma-addons-4.3.1-1.fc10,kdesdk-4.3.1-1.fc10,kdetoys-4.3.1-1.fc10,kdeutils-4.3.1-1.fc10,kde-l10n-4.3.1-2.fc10,oxygen-icon-theme-4.3.1-1.fc10

Comment 6 Rex Dieter 2009-09-08 16:53:52 UTC
*** Bug 519495 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2009-09-09 01:50:05 UTC
akonadi-1.2.1-1.fc11, kdeaccessibility-4.3.1-1.fc11, kdeadmin-4.3.1-1.fc11, kdeartwork-4.3.1-1.fc11, kdebase-4.3.1-2.fc11, kdebase-runtime-4.3.1-1.fc11, kdebase-workspace-4.3.1-1.fc11, kdebindings-4.3.1-3.fc11, kdeedu-4.3.1-1.fc11, kdegames-4.3.1-1.fc11, kdegraphics-4.3.1-1.fc11, kdelibs-4.3.1-3.fc11, kdelibs-experimental-4.3.1-1.fc11, kdemultimedia-4.3.1-1.fc11, kdenetwork-4.3.1-1.fc11, kdepim-4.3.1-1.fc11, kdepim-runtime-4.3.1-1.fc11, kdepimlibs-4.3.1-1.fc11, kdeplasma-addons-4.3.1-1.fc11, kdesdk-4.3.1-1.fc11, kdetoys-4.3.1-1.fc11, kdeutils-4.3.1-1.fc11, kde-l10n-4.3.1-2.fc11, oxygen-icon-theme-4.3.1-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update akonadi kdeaccessibility kdeadmin kdeartwork kdebase kdebase-runtime kdebase-workspace kdebindings kdeedu kdegames kdegraphics kdelibs kdelibs-experimental kdemultimedia kdenetwork kdepim kdepim-runtime kdepimlibs kdeplasma-addons kdesdk kdetoys kdeutils kde-l10n oxygen-icon-theme'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9397

Comment 8 Fedora Update System 2009-09-15 07:37:54 UTC
akonadi-1.2.1-1.fc11, kdeaccessibility-4.3.1-1.fc11, kdeadmin-4.3.1-1.fc11, kdeartwork-4.3.1-1.fc11, kdebase-4.3.1-2.fc11, kdebase-runtime-4.3.1-1.fc11, kdebase-workspace-4.3.1-1.fc11, kdebindings-4.3.1-3.fc11, kdeedu-4.3.1-1.fc11, kdegraphics-4.3.1-1.fc11, kdelibs-4.3.1-3.fc11, kdelibs-experimental-4.3.1-1.fc11, kdemultimedia-4.3.1-1.fc11, kdenetwork-4.3.1-1.fc11, kdepim-4.3.1-1.fc11, kdepim-runtime-4.3.1-1.fc11, kdepimlibs-4.3.1-1.fc11, kdeplasma-addons-4.3.1-1.fc11, kdesdk-4.3.1-1.fc11, kdetoys-4.3.1-1.fc11, kdeutils-4.3.1-1.fc11, kde-l10n-4.3.1-2.fc11, oxygen-icon-theme-4.3.1-1.fc11, kdegames-4.3.1-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2009-09-15 07:39:45 UTC
akonadi-1.2.1-1.fc10, kdeaccessibility-4.3.1-1.fc10, kdeadmin-4.3.1-1.fc10, kdeartwork-4.3.1-1.fc10, kdebase-4.3.1-2.fc10, kdebase-runtime-4.3.1-1.fc10, kdebase-workspace-4.3.1-1.fc10, kdebindings-4.3.1-3.fc10, kdeedu-4.3.1-1.fc10, kdegraphics-4.3.1-1.fc10, kdelibs-4.3.1-3.fc10, kdelibs-experimental-4.3.1-1.fc10, kdemultimedia-4.3.1-1.fc10, kdenetwork-4.3.1-1.fc10, kdepim-4.3.1-1.fc10, kdepim-runtime-4.3.1-1.fc10, kdepimlibs-4.3.1-1.fc10, kdeplasma-addons-4.3.1-1.fc10, kdesdk-4.3.1-1.fc10, kdetoys-4.3.1-1.fc10, kdeutils-4.3.1-1.fc10, kde-l10n-4.3.1-2.fc10, oxygen-icon-theme-4.3.1-1.fc10, kdegames-4.3.1-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.