Bug 519669 - debuginfo package is empty
Summary: debuginfo package is empty
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ksh
Version: 4.8
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Michal Hlavinka
QA Contact: BaseOS QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-27 11:03 UTC by Tomas Smetana
Modified: 2011-02-16 14:08 UTC (History)
3 users (show)

Fixed In Version: ksh-20100621-1.el4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-16 14:08:18 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0226 normal SHIPPED_LIVE ksh bug fix and enhancement update 2011-02-15 16:35:24 UTC

Description Tomas Smetana 2009-08-27 11:03:26 UTC
Description of problem:
The RHEL-4 ksh-debuginfo package is empty (and therefore useless).

Version-Release number of selected component (if applicable):
ksh-20050202-0.5E.4

How reproducible:
always

Steps to Reproduce:
1. rpm -qlp ksh-debuginfo-20050202-0.5E.4.i386.rpm

Actual results:
(contains no files)

Expected results:
Lots of files from /usr/src/debug/...

Additional info:
This is caused by the error in the spec file. It contains the following line in the %install section:

install -c -s -m 755 arch/*/bin/ksh $RPM_BUILD_ROOT/bin/ksh

Note the "-s" install option -- it strips the symbols from the binary... It must be removed.

Comment 1 Tomas Smetana 2009-08-27 11:51:23 UTC
It's even worse than that:  the CCFLAGS are ignored while building the package, so we need to export the CCFLAGS="-O2 -ggdb" first and then call the "package" utility.  Similarly as in RHEL-5 or Fedora...

Comment 9 errata-xmlrpc 2011-02-16 14:08:18 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0226.html


Note You need to log in before you can comment on or make changes to this bug.