Bug 519673 - power hungry application
power hungry application
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11PowerSaving
  Show dependency treegraph
 
Reported: 2009-08-27 07:29 EDT by Marcela Mašláňová
Modified: 2009-09-16 17:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-16 17:23:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcela Mašláňová 2009-08-27 07:29:52 EDT
Description of problem:
pulseaudio consumes lot of my resources even when my system is unable to do any sound.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.16-10.test6.fc12.x86_64

How reproducible:
Upgrade to rawhide. Sound isn't there because something broken in KDE4.3. The power consumption wasn't nice even before but I believed that's caused by playing music. The consumption is almost the same as was on F-11 when I was actually using pulse.

  
Actual results:
Tasks: 180 total,   2 running, 178 sleeping,   0 stopped,   0 zombie
Cpu(s):  6.8%us, 13.7%sy,  0.0%ni, 79.4%id,  0.2%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   2009736k total,  1638104k used,   371632k free,    51196k buffers
Swap:  4268024k total,    79040k used,  4188984k free,   609004k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 1504 root      20   0  315m  51m  14m S 15.8  2.6  34:32.14 X
 1893 marca     20   0 1214m 211m  26m S  9.9 10.8  35:56.88 firefox
 2015 marca      9 -11  480m 4876 3596 S  8.2  0.2  20:20.68 pulseaudio

Expected results:
lower
Comment 1 Lennart Poettering 2009-09-07 11:46:19 EDT
Most likely some application keeps an unpaused connection open with relatively low latency settings. This will cause PA to comply to that and burn CPU needlessly. 

Please attach the output of "pacmd ls" here which should tell us what is going on.
Comment 2 Marcela Mašláňová 2009-09-08 02:25:30 EDT
pulseaudio-0.9.16-13.test7.fc12.x86_64 doesn't have this problem. PA or application which keeps it up was fixed.
Comment 3 Lennart Poettering 2009-09-16 17:23:17 EDT
Closing then.

Note You need to log in before you can comment on or make changes to this bug.