Bug 519681 - system hang at set up after reboot by using dracut ramdisk
Summary: system hang at set up after reboot by using dracut ramdisk
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 11
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-27 12:06 UTC by He Rui
Modified: 2009-09-24 05:19 UTC (History)
2 users (show)

Fixed In Version: 002-2.gitc53acc30.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-24 05:19:27 UTC


Attachments (Terms of Use)
info in the screen when setup (67.93 KB, image/png)
2009-08-27 12:08 UTC, He Rui
no flags Details

Description He Rui 2009-08-27 12:06:38 UTC
Description of problem:
build dracut ramdisk in f11 and use it to the bootloader, and reboot. system hang during setup.

Version-Release number of selected component (if applicable):
dracut-generic-0.9-1.fc11.i586
dracut-0.9-1.fc11.i586

How reproducible:
100%

Steps to Reproduce:
1. https://fedoraproject.org/wiki/QA:Testcase_Dracut_switch_to_locally_built_ramdisk
2. root=/dev/mapper/VolGroup-lv_root
  
Actual results:
hang after reboot

Expected results:
boot normally

Additional info:

Comment 1 He Rui 2009-08-27 12:08:42 UTC
Created attachment 358853 [details]
info in the screen when setup

Comment 2 Harald Hoyer 2009-08-27 15:19:42 UTC
ok, please use dracut-0.9-2.fc11

Latest F-11 dracut packages
If testing on Fedora 11, be sure you are using the latest packages available.
At the time of the test day, the latest packages is dracut-0.9-2.fc11. If
available, you can install the packages from the updates-testing repository:

# yum --enablerepo=updates-testing update dracut

If not available, you can also install directly from the build system:

# yum install koji
# cd $(mktemp -d)
# koji download-build 129497
# rpm -Fvh *.rpm

Comment 3 He Rui 2009-08-28 02:29:36 UTC
WoW, I update dracut to use dracut-0.9-2.fc11, and now it boots normally and works fine. Well done~~@

Comment 4 James Laska 2009-08-28 17:53:51 UTC
Looks like a bodhi update exists for this package (https://admin.fedoraproject.org/updates/dracut-0.9-2.fc11)

Comment 5 Harald Hoyer 2009-09-15 14:06:10 UTC
Here is a new F-11 version to try:
http://koji.fedoraproject.org/koji/buildinfo?buildID=132093

Comment 6 Fedora Update System 2009-09-15 14:12:57 UTC
dracut-001-9.git4d924752.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/dracut-001-9.git4d924752.fc11

Comment 7 He Rui 2009-09-16 10:41:26 UTC
I installed the following in f11:

  dracut-001-9.git4d924752.fc11.i586.rpm (info) (download)
  dracut-generic-001-9.git4d924752.fc11.i586.rpm (info) (download)
  dracut-kernel-001-9.git4d924752.fc11.i586.rpm (info) (download)
  dracut-network-001-9.git4d924752.fc11.i586.rpm (info) (download)
  dracut-tools-001-9.git4d924752.fc11.i586.rpm (info) (download)
  dracut-debuginfo-001-9.git4d924752.fc11.i586.rpm (info) (download) 

but when I tried 'dracut /boot/initrd-generic-`uname -r` `uname -r`', got this:

E: Cannot install a hook (/usr/share/dracut/modules.d/40network/ifname-genrules.sh) that does not exist.
E: Aborting initrd creation.

It seems that /usr/share/dracut/modules.d/40network/ifname-genrules.sh is not in dracut-network-001-9.git4d924752.fc11.i586.

Comment 8 Fedora Update System 2009-09-16 20:36:49 UTC
dracut-001-9.git4d924752.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dracut'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9689

Comment 9 Fedora Update System 2009-09-17 11:13:21 UTC
dracut-001-12.git0f7e10ce.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/dracut-001-12.git0f7e10ce.fc11

Comment 10 Fedora Update System 2009-09-17 16:09:14 UTC
dracut-002-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/dracut-002-1.fc11

Comment 11 Fedora Update System 2009-09-19 00:08:20 UTC
dracut-001-12.git0f7e10ce.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dracut'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9722

Comment 12 Fedora Update System 2009-09-19 00:17:11 UTC
dracut-002-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dracut'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9789

Comment 13 Fedora Update System 2009-09-19 07:01:04 UTC
dracut-002-2.gitc53acc30.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/dracut-002-2.gitc53acc30.fc11

Comment 14 Fedora Update System 2009-09-24 05:19:18 UTC
dracut-002-2.gitc53acc30.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.