Bug 519683 - kernel-2.6.29.6-217.2.8.fc11.x86_64 won't boot
Summary: kernel-2.6.29.6-217.2.8.fc11.x86_64 won't boot
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-27 12:11 UTC by Nelson Chan
Modified: 2010-06-28 14:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-28 14:19:46 UTC


Attachments (Terms of Use)

Description Nelson Chan 2009-08-27 12:11:32 UTC
Description of problem:
first i have to make clear that not only kernel-2.6.29.6-217.2.8.fc11.x86_64 not working, but all kernel from 2.6.29.5 onwards, even 2.6.30 in updates-testing,  only working kernel so far is just  kernel-2.6.29.4-167.fc11.x86_64.

*Note that  i have to boot with nomodeset to make my Xpress 1200 radeon chip functional*
Let me describe how the 2.6.29.6-217.2.8 boot process goes:
First i boot with kernel option  nomodeset,rhgb,quiet,vga=0x323  
With rhgb  the graphics boot screen appears and then disappear immediately, and then boot process no longer continue,  NOTE that kernel not panic and not lock up (still responsive to keyboard).  so i did a ctrl-alt-del to reboot.

Next i boot with only nomodeset option
the kernel throws dozen of messages as usual, but it stops soon. last few message on screen:
---------------------------------------
Mounting sysfs filesystem 
Creating /dev 
...
...
...
... [skip a lot of usb devices etc.]  ....   
Creating initial device node
[drm] Initialized drm 1.1.0 20060810
radeon 0000:01:00.0: PCI INT A -> GSI  18 (level, low) -> IRQ18 
[drm] Initialized radeon 1.30.0 20080528 for 000:01:00.0  on minor 0
---------------------------------------
keyboard is responsive , coz when i hit  keys, something appears on screen.

Later i tried with also  acpi=off  noapic ,  still no luck.

*Apparently, the boot process stop before "Welcome to fedora" text should show up, and after this DRM thing.*

This problem has been around for a while to me, and both of my machine unbootable (2 very different machine, one pentinum 4 M class, and this one Pentinum Dual Core)

###Unfortunately, THERE IS NO LOG  written /var/log/messages ###
The only WORKING kernel is kernel-2.6.29.4-167.fc11.x86_64

    Version-Release number of selected component (if applicable):
kernel-2.6.29.6-217.2.8.fc11.x86_64
kernel-2.6.30.5-32.fc11.x86_64
and the 32bit equivalent

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
I don't mind help in guiding me to gather more information needed.

Comment 1 Nelson Chan 2009-08-29 07:21:46 UTC
kernel-2.6.29.6-217.2.16.fc11.x86_64
doesn't work as well

Comment 2 Nelson Chan 2009-08-31 13:52:20 UTC
interesting, i did a /usr/libexec/plymouth/plymouth-update-initrd trying to change plymouth boot theme.  However, i can't boot to 2.6.29.4.167 again.
So i suspect initrd is causing the problem, making newer kernel won't boot.
(this may also explain why the boot process stop at certain point but not crashed.)

i boot up the installer rescue mode and try to fix it.
accidentally i found /usr/libexec/mkliveinitrd,  i did
/usr/libexec/mkliveinitrd /boot/myinitrd.img  2.6.29.4.167.fc11.x86_64

i apply grub-method and boot the kernel with myinitrd.img works fine again.
(except for a few /dev/loop*  file exists  messages appear when starting udev)

then, i do the same for kernel 2.6.29.6-217.2.16.fc11.x86_64.
/usr/libexec/mkliveinitrd  /boot/myinitrd2.img  2.6.29.6-217.2.16.fc11.x86_64
and it boots fine. except for that /dev/loop messages.

Comment 3 Nelson Chan 2009-08-31 14:45:37 UTC
apparently something has to do with mkinitrd.
because i tried mkinitrd,  but it doesn't work again.
but /usr/libexec/mkliveinitrd works

Comment 4 Honza Ustohal 2009-09-28 09:55:12 UTC
I think I found a solution to this problem. I've experienced the same issue, and I found out, that I can get previously 'invalid' kernel to boot by changing the root parameter in GRUB.

With root=/dev/disk/by-label/root, it did not work, but when I changed the /dev/disk/... to /dev/sda1, everything went smoothly. I guess there must be some problem with partition mappings in newer kernels, which means that it is not possible to specify the partition by its label.

Comment 5 Bug Zapper 2010-04-28 10:00:49 UTC
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Bug Zapper 2010-06-28 14:19:46 UTC
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.