Bug 519694 - archives with binary content handled improperly
archives with binary content handled improperly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-27 09:03 EDT by Milos Jakubicek
Modified: 2009-10-03 15:05 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.91-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-03 15:05:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Jakubicek 2009-08-27 09:03:42 EDT
Description of problem:

Currently, rpmlint complains with "binaryinfo-readelf-failed" if it checks an archive containing binaries. It is because such an archive has pkgfile.magic:

ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV) (gzip compressed data, from Unix, last modified: Thu Aug 27 11:44:01 2009, max compression)

...rpmlint checks for the "ELF" string, finds it, consider the archive itself to be a binary file, tries readelf and fails.

Either we can skip archives, that is easy to change the corresponding line in BinariesCheck.py to:

is_elf = pkgfile.magic.find('ELF') != -1 and pkgfile.magic.find('compressed') == -1

...or we can try to look into the archive contents and check it.

Version-Release number of selected component (if applicable):

rpmlint-0.90-1.fc11.noarch
Comment 1 Ville Skyttä 2009-08-27 11:58:44 EDT
Can you provide a pointer to a package containing such a file/archive?  Before doing anything to rpmlint, I'd like to verify that file(1) is doing the right thing.
Comment 2 Milos Jakubicek 2009-08-27 17:42:25 EDT
Have a look here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1637958

(the package is not yet in Fedora)
Comment 3 Ville Skyttä 2009-08-30 17:10:44 EDT
I took a more generalized magic-from-inside-compressed-files bypass approach upstream; even though BinariesCheck is currently the only consumer of pkgfile.magic, that might change and we'd run into this issue elsewhere (and the problem is not even currently limited to ELF files).

This will probably be in the next > 0.90 upstream release:
http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1641
Comment 4 Fedora Update System 2009-09-13 18:42:10 EDT
rpmlint-0.91-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/rpmlint-0.91-1.fc11
Comment 5 Fedora Update System 2009-09-15 03:42:17 EDT
rpmlint-0.91-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rpmlint'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9562
Comment 6 Fedora Update System 2009-10-03 15:05:09 EDT
rpmlint-0.91-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.